Author Options:

Need to resolve this issue Answered

Please see the attached photo. I use a Canon EOS M3 digital camera, lens removed and C-mount used. Then, an adopter tube is used to connect to the eye lens of my microscope with a LED ring light. In the center of the image, an annoying purple blub always shows up. Tried to change light and microscope. The problem is not resolved. Please help.


My guess is that you have stuck pixels or a greases mark on a lens. Have a look in the menu of your camera you should find "Manual Sensor Cleaning" which can fix stuck pixels. All you have to do is to charge up the batteries and go to the menu and initiate a “Manual Sensor Cleaning” then wait about a half minute then turn off the camera.

Just did that. Improved a little bit, but not totally gone. Thanks

Did you change the light for one of identical type ?

Several lights and settings were tried on at least 3 different microscopes. My colleagues also report similar situations.

Are you diffusing the lights at all?

LED ring light does not have a diffuser. I made one. No help. Tried other diffused lights, same issue.