91Views10Replies

Author Options:

New Editor Feedback Answered

I just used the new editor for the first time, publishing a quick project, and starting a longer one.

Short version: I like it.

I particularly like being able to edit my images via Pixlr. Rotating and cropping on the fly were ideal.

Longer, less-positive version:
  • The "unordered list" and "order list" buttons added neither bullet-points nor numbers.  All they did was indent the text.
  • There is an "intuition breakdown" adding images to steps - when I wanted to add images from my library, I thought I couldn't, until I discovered that the library can be accessed via the "Upload Images" button.  The "Upload Images" button ought to be renamed "Add Images".
  • When using the "Upload Images" pop-up, the actual image upload function did not work.  I clicked the button, and nothing happened - no error message, no wait symbol, nothing.

This is all experienced using my desk-top PC, running Windows XP and FireFox.


Discussions

0
None
mikeasaurus

4 years ago

Thanks for the feedback. I've encountered a few of these myself. These have been passed onto our Dev team to investigate and add to an upcoming release to fix.

0
None
Kitemanmikeasaurus

Reply 4 years ago

Cool. I haven't delved into the deeper corners, like embedding videos, but I may soon, and I'll add more feedback as necessary.

0
None
pseatonKiteman

Reply 4 years ago

Yes, thank you for the feedback! I was a little concerned about your point #3 above; I haven't heard any reports about uploading not working at all so I thought I'd follow up. First things first, does the uploader look like the attached screenshot when you first open the modal?

Screen Shot 2013-11-26 at 11.35.04 AM.png
0
None
Kitemanpseaton

Reply 4 years ago

Yup, looks exactly like that. When I click on the Upload button, I can see the "press" animation happen, but nothing else.

0
None
KitemanKiteman

Reply 4 years ago

Oh, wait, it's me, not a bug!!

I hadn't realised that the "browse" button is the same as the old "choose files" button!

OK, scrap #3 as a bug, re-title it as a failure in intuitive use. Probably a new user wouldn't have had the problem, but habit-bound me just didn't make the link. maybe, while you're relabelling buttons, that could be renamed "choose files" or "choose images" as well?

0
None
pseatonKiteman

Reply 4 years ago

Indeed! I'll poll people on that one. I think "browse" might be more globally understood than the "choose files" that's been our norm, but I wonder also if "Browse" should be the bright orange button until you've selected images, then "Done" could turn orange instead.

0
None
Kitemanpseaton

Reply 4 years ago

Ah, the Ivan Pavlov school of web design...

0
None
pseatonpseaton

Reply 4 years ago

Not to belittle your other points by the way! A fix for #1 is on its way out the door, and we're working on changing those button labels soon....

0
None
mikeasaurusKiteman

Reply 4 years ago

Can you try your error #3 again after refreshing the page? What exactly doesn't work? Sometimes when uploading lots of images the pop-up scrolls to the bottom and you can't see the upload progress until you scroll back up.