Author Options:

New release - new commenting! Answered

There's been a new release of the site!
Read more below and leave your thoughts in the new comments section.

The commenting has changed slightly, there is now no "rich editor button". It's been replaced by highlighting the text and the formatting options float on top. Also when commenting, when you click the 'add images' you may notice that the new image uploader modal (the same one used in the new editor) replaces the old image uploader.

If you don't see these changes you need to clear your browser cache (not just cookies). Then, refresh the page and click in the comments box.

As with all changes to the site, we're experimenting to see how this rolls out and what we need to tweak. We're going to stick with this for now and gather some data. Please leave your feedback below!


Great feedback. Please keep it coming!

Was there a reason for removing the number of instructables from below avatars, or is it a bug/unexploited feature?

This info is now available when you mouse over the avatar!

Ah, another feature that does not work well on a touch-screen device...

The changes sound good! :-)


4 years ago

Mike has it well said

First time using the site with a keyboard device since the update...

I can bold, italicise, underline and add links or videos, but where are the options for sub & super script? Or for special symbols?

For special symbols you can take a look at my Instructables Enhancer, which, withunder, brings back the rich editor where the special symbols and sub & super script etc still are.

Sub and superscript might be a while, they were a feature that many people used as a novelty instead of for mathematical functions. Ditto, for special symbols. I know there's a legitimate case for them, but we're working on adding some more functional formatting options like numbered lists and quotations first. Stay tuned!


4 years ago

Are you still sending out author updates? BY that I mean do announcements still get sent out to those following someone when they publish something new. The reason I ask is that when I lately published a new instructable I didn't get an author update and since I am one of my followers (I have to follow myself otherwise I get lost, circuler thinking ) I should have gotten an email if it was still working. Or maybe I broke it, rats.

We were having trouble with the system sending out multiple notifications. We've turned those off for now. Sorry!

Something has changed as part of the new rollout. It seems that Instructables has hijacked the normal arrow-key controls. On Firefox, up and down arrows are supposed to scroll the page step-wise, a bit at a time. Now, on this site (and only this site), both up-arrow and down-arrow jump to the bottom of the page, which is extremely annoying.

Weird, i can't reproduce that on firefox or chrome.

Wups. It's even more specific than I thought! I just caught myself using the up/down arrows on the step-by-step browsing page, and they work normally. Similarly on both the Answers browsing page, and on individual answers.

It is only when looking at a single forum topic (like this one!), that the up/down arrows both jump you to the bottom of the page. At least with Firefox. Let's see what Safari does...

Heh. On Safari, the arrow keys, and the Fn-arrow keys, all do exactly what they normally do when browsing. Sigh.

Did the change affect commenting on Apple devices? I have both an Ipad mini and an Iphone 5 on ios 7 that have trouble commenting. When I leave a comment, the grey pop-up appears and says "missing comment text," even when I in fact did type something. The only ways I can comment now are through my "discussions" page and the ios app, which doesn't let me reply, either. I will repost this in the "bugs" forum as well. This comment was typed from my Ipod touch that runs ios 6.1.5 and still can reply.

But the change is good in part, I used it to italicize words in this comment. :)

So how do write Greek letters now, without my buddy Rich Ed?



Wow! I can't believe that worked! And I still kinda wish I could preview it first.

So entities (&something;) still work? I was only able to get raw HTML to work before I reloaded the .js file.

Yeah. Entities, ampersand-somthing-semicolon, is how I did that, and it worked for me about two hours ago. Um, lemme try it again:

c = λ*f

Testing on a very old MacBook and the floating formatting thingie works fine, as well as underlining misspelled items. Quite a bit easier than the old comment window. Thanks!

cool keyboard shortcuts uses both the command keys and control keys on mac.

Testing on an android tablet...

... and no formatting option floating thingie.

Cleared the cache, and...

Oh, it nearly worked - I highlighted text, tapped the highlighted text, and saw the formatting pop-up for a second or so, but the highlighted text unhighlighted at the same time, and the pop-up disappeared before I could use it.

Trying ag if I highlight a word, I can switch on an option to type from the point I tap (I tapped the word "again" here), but I can't change the actual word I highlighted ain

Why did the rich editor get removed, I really liked being able to enter HTML in my comments, most of all using the img tag.

Testing the commenting, including photos.

Agree with commenting below - image uploader just stalls.

The highlighting thing works here, however, the image uploader doesn't. I can select a picture, but after hitting upload, it just keeps saying 'ready for upload' without doing anything.

It works from here. It's not very flexible though, will we get the html option back?

Testing the highlight. Nope. Nothing "floats on top." And the conventional "control keys" (Cmd-B for bold, Cmd-I for italic) don't work. I wonder if HTML markup works?

Oh, there's no Preview! Okay, I'll just post this comment and see what happens.

You need to clear the browser cache. If you still can't get it to work your browser will download the new javascript file after your old one expires (or you can manually remove it to force a download - commentcontrol.js)

Hi, Mike. I did clear the cache, no luck. And that filename isn't found.

....Ah, ha. It's called "CommentControl.js" (filenames are case sensitive). Let's try loading it....

And there it is! A little black talking bubble popped up when I hit [Reply]. And now, when I highlight text, I get the [B I U...] popup. Do control keys work? Hmmm... yes, they do. Thanks, Mike.

No problem. I went through the same exercise yesterday trying to get it to work. We're still experimenting with the formatting options, so it's not set in stone yet.

Also, if anyone else has cache clearing issues, teh JS file will refresh for return users in about 24 hours automatically.