82Views14Replies

Author Options:

Not accepting 3rd party cookies at Instructables.com preventing commenting Answered

I've turned off acceptance of all 3rd party cookies in my browser.

Because of this, I am not able to post a comment to anyone's Instructable.
  1. I get how analytics help drive your business, so you need to use a server based solution vs using client-side (using 3rd party pixel.quantserve.com click/data capture) to do so [I'm accepting cookies from your domain].
  2. Blocking 3rd party cookies is pretty common.  [Mozzilla was even considering making it the default, before enough lobbyists have complained that Congress sent a letter to Mozzilla asking that they not do that]
  3. Accepting the quantserve cookie, as a REQUIREMENT for commenting is just not kewl!

Discussions

0
None
mikeasaurus

5 years ago

Good sleuthing, Zac!

Thanks for your very detailed report, I can replicate this on my browser. We'll investigate this from our end and see if we can get that bottom comment box working correctly.

Please feel free to email us anytime at service@instructables.com with any other concerns.

0
None
ZacWolfmikeasaurus

Reply 5 years ago

Thanks for your speedy attention to this! I'm really impressed! :)

0
None
ZacWolf

5 years ago

OK, so here is the issue as I understand it so far...

If I do not accept the cookie from pixel.quintserve.com I am seeing a 2nd "add comment" box at the bottom of an Instructables comments section. In that 2nd "add comment" box, none of the buttons are working (which is why it seemed like I was unable to comment).

When I accept the cookie (and reload the instructable), I don't see the 2nd "add comment" box. The top [real] add comment box allows me to comment with or without the quaintserve.com cookie, so NO UNKEWL TRACKING COOKIE REQUIRED TO COMMENT ISSUE {phew}.

But, not accepting this cookie means I'm getting that extra add comment box which doesn't work, which might confuse people.

When kelsymh tested (from CA?) they are not seeing the two 3rd party cookies that I am seeing at all.  Is instructables.com operated in a multi-regonal data-center configuration (globally distributed content servers)?  If so, then possibly the server that I'm seeing (from Durham, NC) may be the culprit?  It's sending a tracking cookie, that the CA server is not?  Thats my theory...

If that's so, then in a worse case scenario, someone has possibly planted a web-server config property that is allowing them to track users without you guys even knowing?


0
None
kelseymh

5 years ago

I also block third party cookies.

I've just checked that I do not currently have a cookie from Quantserve. What's more, in my (long!) list of "Exceptions - Cookies", I don't even see quantserve.com or pixel.quantserve.com listed; that usually means they haven't requested to use a cookie on my machine.

After I post this, I'm going to dump all cookies and all exceptions, and see what happens. What you describe isn't cool, and if it's real, it should be brought to Staff's attention.

0
None
kelseymhkelseymh

Reply 5 years ago

Now I'm trying a reply. No change, and no request from Quantserve.

...Oh, you said it was comments on an I'ble. I'll go to one of my own and try (though I've posted comments this morning, and had no Quantserve cookie issues).

0
None
ZacWolfkelseymh

Reply 5 years ago

When I tested posting a comment to my OWN Instructable, I was able to comment, but I still saw two cookies rejected:

pixel.quaintserve.com
b.scorecardresearch.com

I even turned off all of my extensions, in case any were injecting the cookies.

I just tried again with someone else's Instructable. Using the add comment box at the Top of the comment thread WORKED, but when I tried adding a comment via the BOTTOM comment box it did not work!

0
None
ZacWolfZacWolf

Reply 5 years ago

It would seem that NOT accepting the pixel.quantserve.com is WHY I'm getting a second comment box at the BOTTOM of the page to begin with, which explains why none of the button in that box are working...

If I accept that cookie, then reload the page, I'm only getting ONE "add comment" box, at the TOP of the comments section, and all it's buttons are working.

OK, so my guess is that

0
None
kelseymhZacWolf

Reply 5 years ago

I think your analysis (in your featured comment) is interesting. I do not see the second (bottom of page) comment box at all. So maybe it is a JavaScript out-of-synch problem with their different servers.

I've sent a PM to Mikeasuarus, who is I'ble's bug/problem liaison on Staff. Hopefully he'll post here or otherwise get in touch with you. The "service" e-mail address is also very good for getting a human response.

0
None
ZacWolfZacWolf

Reply 5 years ago

It's possibly a javascript issue. Do you guys use a region based CDN, or is everything coming out of a single data center?

If it's a regional CDN, possibly one of the region servers is configured to plant this cookie (which is explains why I'm seeing it, and you're not).

0
None
kelseymh

5 years ago

I'm trying a top-level comment, with everything cleared. So far, only "instructables.com" has requested cook access, which I have allowed, and it has created nine cookies.

0
None
ZacWolfkelseymh

Reply 5 years ago

I have a screenshot of the 3rd party cookies being rejected (two of them), is there an email address I could send them to?

Your "Select Files" functionality doesn't work for me, since it is based on a Flash plugin, and I have that limited not to create data on my machine.

0
None
kelseymhZacWolf

Reply 5 years ago

Regarding the "Select Files" issue, the "old uploader" (it's a non-URL hyperlink on the upload box) doesn't use Flash, and should work for you.

0
None
kelseymhZacWolf

Reply 5 years ago

I would send it to service (at) instructables.com, along with a link to this forum topic. As with bug reports, include your platform type and browser version. If there's a particular I'ble or forum topic where this showed up, include that URL as well.

Requiring third-party cookies are Not Okay. I am surprised that this isn't a "universal" problem (i.e., it is affecting you, but not affecting me). Hopefully Staff can identify what's going on, and either eliminate it or explain clearly and acceptably why it's important.

0
None
ZacWolfZacWolf

Reply 5 years ago

I tested the functionality, by temporarily accepting the cookie from pixel.quantserve.com and I was able to comment then.