180Views23Replies

Author Options:

Notes in pictures... Answered

I am about to submit an instructable and would like to add notes to my pictures but it never saves the note.

Everything seems to work fine (I can draw the box and add the note) until I hit save.  When I hit save the dial indicator just spins and nothing happens.  I can walk away from my computer for 20 minues and when I get back it will still be spinning trying to save the note.

I thought it might be my connection from home, but I have since tried it on my computer at work with the same result.

Has anyone else had this problem?

Thanks in advance.

Discussions

0
user
ilpug

7 years ago

A random tidbit of information that might be realvent. i am having the same error everyone else is, but when i try to make notes on Internet Explorer, the little spinner spins for a second only and then stops. also, has anyone tried to save notes on the Camino browser, or in a cached version of the page?

0
user
jeff-o

7 years ago

So far, it seems to be related to "illegal" characters in the note text. For now, avoid using commas ( , ) slashes ( / ) and colons ( : ). Periods still work, as for symbols like the exclamation point and ampersand.

use mozilla firefox it works fine for me so im gonna use that for publishing instructibles

yep.... can't add notes... really sucks.

I am also having this problem, even after removing colons.

The notes function is still not working properly.

This is apparently a known, and hard to fix, bug. If you search for "image notes bug" you'll find several reports. The latest information from Staff is that it could require a "rewrite of the autosave Java code" to eliminate it.

If you could edit your original text above to include browser and OS information, that'll help Staff in documenting where they need to test.

As far as I have noticed, the bug is activated when a colon is in the text.
I just posted this: https://www.instructables.com/id/Lego-flower-vase/
and I had errors many, many times when making image notes - and I tested in three different browsers. But only in texts that included a colon. Each time I removed colon from text: no error.

But the images are displayed twice in the page - An error I couldn't correct - Can anyone help?

Could you put that up as a separate bug report? That kind of detail could be very useful to the Staff in tracking down the specific problem!

His username has a Unicode character (o-umlaut); not all browsers or fonts are fully Unicode compliant, even today.

Yes, it does seem like a rather oldfasioned problem :D
But suprisingly it's still common.
Anyway, I just changed my username :)

The problem is that with I'bles software, they use your username as part of the URL path to get to your profile information. Unicode is not support for URLs (only 7-bit ASCII, with some reserved characters excluded). You'll find a small number of non-ASCII usernames here on I'bles, and they are uniformly unreadable :-)

:-) I can imagine! It's been surprising to me just how long it has taken for proper internationalization to really take hold.

Some of the limitations early in the development of Internet protocols (e-mail as well as http and HTML) were driven by the technology of the time, and once in place are very hard to change.

Nevertheless, the ASCII-centric nature of the Web has been a significant barrier to access for most of the world outside of Western Europe.

Ah, I assumed that was a problem with the backend (similar to how foreign language characters often get messed up). The More You Know!

I thought staff would read it here - but ok i'll do that.

Thanks! It is much easier for the Staff to keep track of bugs by referencing specific forum topics in their database, rather than having to search through comments for different issues.

I actually did search a little before posting and of course it wasn't until AFTER I decided to post my comment that I found some other reports. I feel stupid!

No reason to feel stupid, per se. Multiple bug reports can remind staff that the problem is still around and widespread. Unfortunately, it doesn't seem likely to be fixed quickly :-(

Yup, still messing up notes, that and the notes from 1 pic is transferring to others.

The adding notes function is sometimes wonky. I have found that if you can't add a note when doing the editing of an instructable, wait till after it is published to go add the notes when you view the ible. Sometimes your notes will not appear until after you switch to the second picture in a step. Sometimes your notes will only work if you manually hit save to save the step in editing.

What kind of instructable are you doing a photo or a step-by-step? Which browser and operating system are you using? Ibles is optimized for Firefox but I jump between IE and Chrome also to get things working.

Thanks for the reply. The notes are not super important so I will publish it anyway (just need to finish a video first). I will take your suggestion and publish it, then go back and see if I can add the notes.

I manually save "constantly". I guess I am so used to programs crashing that it has become automatic to save everything all the time.

I am doing a step-by-step instructable, using Internet Explorer 8 (home) Explorer 7 (at work), and both computers are running Windows XP.

Again, thank you for the suggestions.