2310Views16Replies

Author Options:

Problem connecting a USB device. Breadboarded USBasp programmer circuit detected as 'Other Device' on connecting to PC. Answered


Dear techie

I am trying to build a USBasp programmer with the ATmega 8 microcontroller and have successfully breadborded  it along with the other passive elements.

The problem arose when on connecting with the PC through a USB cable, a message flickered saying that the device has malfunctioned and won't work correctly. Further the progammer was listed as 'Other Device' in the Device manager of Windows xp. Even when I try to manually  load the driver for the USBasp, the wizard said that it couldn't find a better driver than the present one and didn't load the actual driver(lib_usb.dll).

USBasp is compatible with Windows xp which is my current OS.

Please help.

Discussions

0
None
GOKUL SISODIYA

3 years ago

in windows xp when usbasp conected its displays unknown device in universal usb port in device manager and i want to update driver it displays cannot installed the driver

0
None
steveastrouk

8 years ago

Have you flashed the Atmega with the the USBasp firmware ?

0
None
ygshsteveastrouk

Answer 8 years ago

I could not do so as my PC is not recognising the programmer as a USB device.

0
None
steveastroukygsh

Answer 8 years ago

No, I think you've missed the point, you need an SPI programmer to PUT the USB code into the device.

I refer to the README.TXT file in the USBASP source files. "

BUILDING AND INSTALLING FROM SOURCE CODE

Firmware:
To compile the firmware
1. install the GNU toolchain for AVR microcontrollers (avr-gcc, avr-libc),
2. change directory to firmware/
3. run "make main.hex"
4. flash "main.hex" to the ATMega(4)8. E.g. with uisp or avrdude (check the Makefile option "make flash"). To flash the firmware you have to set jumper J2 and connect USBasp to a working programmer.
You have to change the fuse bits for external crystal, (check the Makefile
option "make fuses").


0
None
ygshsteveastrouk

Answer 8 years ago

Sorry for such a delayed reply.

Coming to the point, I've tried to flash atmega8 using a self built serial In System Programmer which is connected to the PC via the LPT3 printer port. But all the programmer software be it PonyProg or the ISP Programmer 1.2.0.53 or the avrdude-gui, are unable to recognise the microcontroller saying, " device missing or unknown device(-24) "," bad signature or device not known " and " error 2: the system cannot find the file specified. " respectively.

I've tried changing the microcontroller to no help. Is there something wrong with the port or my ISP programmer hardware?

0
None
steveastroukygsh

Answer 8 years ago

I'd suspect the port. Is it a "real" parallel port or a USB simulation ?

Steve

0
None
ygshsteveastrouk

Answer 8 years ago

It is a parallel port.
By the way the avrdude -CUI reported an error: ser_open() : can't set buffers for "LPT3". Does this confirm the problem ?

0
None
seandogue

8 years ago

Sounds like you have a comm-flict. Check your comports to make sure something else isn't already using the comm port the USB interface expects to use.

0
None
ygshseandogue

Answer 8 years ago

Thanks, but there isn't any comm-flict. I have verfied this by connecting other USB devices

0
None
seandogueygsh

Answer 8 years ago

darn. seemed likely. It's what I've seen most times when I get that error.

When you say you've connected other usb devices, you mean to the exact same port?

Hmm...also, I don't think you can simply jump to the conclusion that there isn't a comport conflict by simply plugging other devices. the device you're encountering a problem with may be less flexible than the other devices used to test the connection and may require a specific comport and address to ensure successful connection.


0
None
LoganRussell

8 years ago

I don't know. You might of did some bad wiring. Otherwise, I don't know.

0
None
LoganRusselllemonie

Answer 8 years ago

all i was trying to do is help him out. Cause when I get that error it normally has to do with the wiring.

0
None
lemonieLoganRussell

Answer 8 years ago

Yes but you were vague and said "I don' know" twice. I don't know either, but I think Steve' might.

L