Author Options:

Quadcopter build help? multiwii is causing motors to twitch when throttle is applied Answered

I have been working on a large X525 quadcopter kit/ w/ multiwii SE v2.5 from amazon, and have had success with configuring the multiwii for the quadX configuration, however, when I arm it and try to take off, all 4 motors ramp up to speed but then cut out and continue ramping up, particularly one motor, whichever is the lowest. Balancing the quad on 2 legs, the quad seems to want to stabilize, but keeps tetering violently since the motors keep randomly cutting out.

I have tried to calibrate the ESCs by connecting them individually directly to the CH3 (throttle) receiver, powering up the Tx with the throttle high,plugging in the LiPo battery, and after hearing the jingle, lowering the throttle back down to the lowest position and waiting for the first few beeps before I unplug the LiPo battery and moving on the the next ESC.

I was looking at the multiwii outputs through the software and they were in fact jumping around like crazy but after taking the props off the amount of twitching did go down a little, but still about 10-20% deviation in the bars of the software readouts. I've also tried dismounting the multiwii from the quad to eliminate the possibility of vibration from the motors from causing the multiwii to attempt corrections to the motor. though it seems to have the same for as long as I could tell because by the time I tested this, the multiwii board touched the power distribution board causing magical smoke to be released. Oops! Now the multiwii is completely dead all but the green power light which is directly connected to power Vin.

The board and all the chips appear completely fine with no damage, and there is voltage to the main ATmega328, I don't know if I should try desoldering the ATmega and buying a replacement, or suck it up and buy a new $30 board. For all I can tell, I do not see how other sensors could have failed since the the exposed through-hole headers that likely touched the distribution board are directly connected to the multiwii's analog/digital input/output pins, I suspect that is all that went bad is the ATmega chip, even though if shows no sign of burning and does not overheat with power applied.

Anyway while I wait, I thought I will ask about this problem to see if it is something simple like sensors calibration. (w/o motors operating, the output appears as it should!!!)



3 years ago

That sure sounds like current starved power especially when it improves with less load ie No Props !

Motors accelerating to speed, draw 4 to 8 times the spec current and you are ether overloading your LiPo battery or the wiring is not heavy enough gauge.

You can try winding up two motors at a time, but more battery will really help.

I thought the same thing, and used to really thick wires and power distribution board that came with the kit. It certainly looks like it can deliver the power, and voltage does not sag a lot. It seems like the MultiWii was telling the ESC to Jerk that way, looking at the program bargraphs of the motor output.

Strangely they were not jumpy before ESC are connected. Could it be horribly unbalanced props and motors?

Easy enough to disconnect and test motors individually on a battery.

Personally, it almost seems like there is some sort of feedback loop back to the MultiWii. As far as I know the only feedback mechanism is the sensors (gyro, accelerometer, manometer, barometer, etc.) everything except when I dismounted the board lead me to that conclusion, though I do not feel like I tested that adequately, since clumsy me did not do enough to prevent the power distribution board from touching the MultiWii, and of course after letting the order go to walk over to the computer I let out a tiny about of magic smoke! I will have to wait a while for my new one to ship and arrive, this time, I will put tape on all the exposed metal on the bottom of the board like I did with my Arduino mega.