Author Options:

[Raspberry Pi] Does anyone have WiFi working with RetroPie? Answered

In short, I have two Raspberry Pis - one running the regular distribution of Raspbian, and one running RetroPie, which is built on top of Raspbian. I got the popular Edimax EW-7811Un USB wifi adapter, which worked like a charm right away with regular Raspbian, but for the life of me I cannot get it to work with RetroPie*. I've gone through various troubleshooting steps, and already posted a more detailed description on the official Raspberry Pi forums (thread here if you're interested in the details...no responses yet). 

Just curious if anyone here has run into the same issue, and if you found a workaround. I'm a complete Linux amateur so keeping any explanations beginner-friendly would be much appreciated.


*This isn't for online gaming, I want to be able to do other things like voice control on the same machine, which requires internet access.


Whenever I try to startx a white window launches in the top left corner with system resource info and a bunny stuck at a prompt I can't type at. I tried this with beta 3 then downloaded and try with RC1 v3 and got the same results. Any idea why?

No idea, unfortunately. My original post is over a year and a half old, both Raspbian and Retropie have new versions since then, so this is probably obsolete. You might be better off on the official Raspberry Pi or Retropie forums.

Answering my own question just in case anyone stumbles across this in the future: I was able to get WiFi working by starting over with a clean slate:

  1. Re-flash the SD card

2. On first RetroPie bootup, when it brings you to the Player 1 button mapping screen, press F4 to exit RetroPie and go back to the command prompt.

3. Type startx to enter the normal desktop environment.

4. Use wpa_gui to set up wifi like you normally would. I didn't have any issues recognizing or connecting to the network this time.

5. Open a terminal and type emultationstation to re-start RetroPie. It should go back to the controller mapping screen and you can proceed as usual.

So, I'm not sure what happened...maybe some combination of setting up the USB controllers first along with having everything plugged into a single powered USB hub irrevocably screwed up communication with the USB wifi dongle. To be safe, on the second time around, I plugged the wifi dongle directly into one of the Pi's USB ports, and everything else into the hub.

Thank you for following up man, you're a hero. This worked for me as well.

Thanks dude! I will have to try and get this set up. I thought about having the pi run some kind of rotating online program when not in use for gaming. I have the pi in an old arcade cocktail cabinet.