Author Options:

Repairing Sonicare Elite Pro Answered

My Sonicare Elite pro after a little less than 2 years stopped working. To ascertain where the problem is I opened it up following the operator’s instruction of Philips which tells you how to permanently open it to dispose the Ni-Cd batteries. I found that there is only one battery (in other models I saw that there are 2 units, apparently serial wired) and the voltage across the battery terminal is 1,3-1,15 V. The green blinking LEDS seem to work all right when the charger is applied and the full set of lit LED should indicate that the battery is charged. But the vibrator does not work. It would help to know which is the operating voltage of the battery as it seems a bit too fat to be an ordinary AA 1,5 V battery. Any help is appreciated.


Thanks Trebuchet I tried the reset and in the end my Sonicare works again. I also thoroughly cleaned the PCB and the SMT components just in case. When I opened the unit, in fact, above the O-ring i saw a heap of crust and dirtyness. The thing is not designed to be fully waterproof and some humidity might have sneaked into the unit thus causing some troubles to the electronics wiring. Anyway now it works. I am double satisfied as I have been able to fool Philips who no doubt design these components in a way that they breakdown after a certain time, so as to buy a new one. Thanks to all for the help and Merry Xmas.

I have an older model (not an Elite Pro) -- but something similar happened to me after a year of use... It would seem like it was charging, but nothing happened when I turned it on.... After exhausting all my options (other than buying a new one), I decided to do a soft reset. Put it in the charger (with it plugged in of course) and then hold down on the power button for something like 5-10 seconds. I think it either beeps or flashes (can't remember) and the first use settings are reset (so the first brushes are less intense). It then worked normal for me. --Just passing along my past experience :P

Thanks for your advice. The battery is only one piece. Meanwhile I went further on. When I depress the start button I can hear a very faint buzz and the coil of the vibrator gets warm, but no vibrations can be appreciated; it thus look like the thing is trying to work but the command signals or whatever are too weak. The components on the PCB are all SMT without any indication. Before I try to increase the voltage at the Battery terminals I would like some more advice.

Judging from your first picture, the chip on the right (U1) appears to be the charging circuit. If you place the device in the charger and measure the battery terminals while it's charging (VCC to GND on the board), it should give you an idea what the battery's voltage should be.

If you can remove or rotate that battery to locate a part number, it would be a big help. That "0412" is a date code indicating December, 2004. Once you've located a part number, try this site, among others to locate a replacement.

That black collar around the battery, could it be that it's hiding that that's in fact two batteries? It may be a pair of 1/3 or 1/2 A's.