Author Options:

RetroPie system hanging problems Answered

Not too long ago I ordered a Raspberry Pi 3 and used it as my main computer for about a day and while it did most things pretty well, internet browsing, as usual, was painful, with the browser tabs loading very slowly and crashing frequently, probably due to the small about of RAM and poor RAM management. Anyways I decided that while the Pi 3 may still not be suitable for me in desktop use, what about game emulation!?!?


So I download the RetroPie distro and flash that to a quality SD card, and get it set up. I installed a few experimental emulators and messed with the CPU/GPU RAM allocation a bit but any time I try to emulate a system, or even exit an emulator and get back to the emulation station, the entire system hangs!!!!

Being a hardware guy, I get the osciloscope and measure the power supply. I did notice that when the PS3 is connected via USB, the red light on the Pi goes out. Surely enough the red light goes out because the nominal 5V input drops to below 4.5V, which causes the 1.1V regulator powering the processor to drop out for some reason. I replaced the dodgy 6 ft USB cable and 5V 2A power adapter with a much shorter 2 foot long and thick micro USB cable and use a quality samsung 5.3V 2.5A charger, and this seemed to fix that problem and reduce the frequency of system hangs. Now I can no longer observe a correlation between a system hang and low voltage dropout. The minimum voltage observed was 4.8V.

However I still sometimes get system hangs when exiting emulators, and it is just about guaranteed to hang when trying to use the SNES, N64, and PSP emulators. I might try to reflash RetroPie over this weekend if I have time, but I want to know if anyone else had this problem or might have a solution.

The SD card used was a 32GB SONY UHS1 card nominally rated at 40MB/s transfer rate, and benchmarked the highest of all my 32GB cards with 4Kbyte random read/write. I used Win32DiskImager to flash the card in windows 10.



2 years ago

No answers yet... :(

Well I think this problem might have to do with either getting a bluetooth connection between PS3 remote and retroPie, or a unstable package when I sudo apt get upgrade. I was emulating systems without much problem until I sudo apt get update, sudo apt-get upgrade and sudo reboot. Without performing the updates I could not get the PS3 to wirelessly pair to the Pi. My USB cables are too short so that is not a solution either. Now I am back to the same old problems.

Hi, My experience with the Pi was that I got impatient. I was judging it by the speed of my desk top machine which is a different beast. When I thought it was frozen it was just trying to do memory management to get things done.

My son runs 3 Pi's 1 as a music server, 1 as a video server to

record video and TV and 1 as a web server. he finds them very reliable and effective.

It might be worth stripping things down to a minimum and slowly adding the peripherals back to see if you can identify the bottle neck. may take a lot of investigative work though.

I built an arcade cabinet with my son but it has an old PC in it he is considering revamping it as a table top system running on a Pi.


I'm pretty sure if it remains in a locked up state for over 24 hours something is not right. Maybe a certain processing thread is locking up a memory location and the processor is getting into some sort of deadlock, IDK. How do I uninstall the latest updates in the CLI?

None of those commands let me uninstall the most recent updates. I'd imagine that would require a bit more effort because I don't think such information / log is kept. Those commands use apt by itself, rather than apt-get. Is there a difference? Does apt-get install packages meant for x86?

To be honest I don't know as I haven't needed to uninstall updates.

try one of the Pi forums you may get more specailsed help there.

I had a word with my son onj

this question but as always complex connections lead to complex problems. he agrees with me that trying to isolate the problem is most likely to give the best results,

His reply to me.

"Hmm, not sure. You definitely need to use a quality power supply and I'd
recommend to ensure both the system and firmware are up to date:

sudo apt-get update
sudo rpi-update"

But you already did all that.

I cannot get sudo rpi-update to work. When I first tried to run it The CLI returned command not found. It was not even installed. After installing then running it, it "!!! Failed to download update for rpi-update".

I think your going to have to reduce the system to the minimum update and then start adding bits to see what causes the problem.

Of course you may find you have to have it all together to get the problem. :-( nature of computing I am afraid, complex systems generate complex problems.

OK, it might have something to do with using the PS3 controller wirelessly... the N64 emulator (the one that crashes most frequently) does not seem to have problems when the PS3 remote is wired. :/ Which is disapointing because I want to use it wirelessly.

I'll try sudo rpi update and see if that solves any problem. For a moment it seemed like the culprit was a bit of aluminum sheet metal cut to size used as a heat sink, as I noticed the system was stable without it. IDK why it would cause a problem, maybe parasitic capacitive coupling to the GHz speeds on the board, other people operate the Pi with heatsinks. Then after launching the N64 emulator the problems came right back with vengeance!

Pick up resetting all micro controllers is a bugger. Could be something wild like the game is creating RF radiation with a particular series of commands at that point and resetting things. The Pi is very tightly packed.