Author Options:

SONY Flash Drive HELP!!! Answered

Help!!! Today I had my flash drive with me and was working on some school projects. It worked fine in the morning. Though later I was messing with Batch and saved them to the drive root. Now when I plug it in windows waits for about a min. then says that new hardware was found. When it's done it says that the device is malfunctioned. I don't know what to do or if that batch file is even the problem. If it is I think that it changed the devices properties into making windows think it is bootable. I have plugged it into my Linux machine but still no dice. It won't even come up there. Oh, and I can't reformat it because it's in a way not there. I really need those files for school any way to get them back would be great. Any help would be greatly appreciated.


go to a linux box get root (su) fdisk -l stick the usb in and wait few sec fdisk -l the new thing is the usb disk. if it has partitions (like sdb1 etc) then try to use them. if not then try to use the entire device (sdb) mkdir /media/k (or use an existing folder) mount -t vfat /dev/sdb1 /media/k chmod 777 /media/k open file manager as user and go to there at the end : close all open windows that used the disk as root : umount /media/k wait untill next line in the console appears and is not an error now its ok to remove

I'll try but who knows...I think its dead :( Thanks Though For the help!

some more things to try in the linux box get root and enter lsusb with and without the thing plugged in (shows if its detected at all) it may be broken link in the place where the usb head and the circuit board inside connect. try to press it to different sides maybe one of them shall work ok. to fix open it and solder the 4 contacts

i thought that may be the case ill check that too thanks!

even if a device doesn't immediately show up (no icon, that is) you can still find it in a sense by digging through a UNIX directory (as you would with linux). What you want is the linux terminal, once there, type "cd /dev" You may have to dig around a bit, but that will hopefully get you started

I'll give that a go but it won't show up anywhere even in dos or in the terminal.

That sucks, I backup my usb as much as possible cause I'm scarred I'll lose it (panick attack about once every 3 days, why do they make them so small, and why'd I have to get it!!! smaller than a quarter...) hmmm.... so it doesn't recognize it as a usb drive at all?