212Views21Replies

Author Options:

There's been a problem updating your Instructable parsererror : Unexpected token Answered

Working on a draft, was editing tags in images when suddenly...

I can no longer access this step at all, not even to delete it.

Discussions

0
None
mikeasaurus

5 years ago

We just released a new version of our editor that should fix all these errors. Try editing your project again!

0
None
RedBinarymikeasaurus

Reply 5 years ago

I'd love to test this out, but a staff member deleted it back a bit after our discussion. I see the offending image in the comments below, but cannot find it in my image library.

0
None
mikeasaurus

5 years ago

Can you please send me a link to your unpublished project so I can take a look?

0
None
BrittLivmikeasaurus

Reply 5 years ago

Thank you for the fix, I could finally edit one of my instructables, that displayed this error for about half a year.

0
None
RedBinarymikeasaurus

Reply 5 years ago

I see you're an editor here! Any chance you can get help that apostrophe edited out?

0
None
RedBinarymikeasaurus

Reply 5 years ago

For clarification - it is the image linked below that has the specific issue.

0
None
RedBinarymikeasaurus

Reply 5 years ago

I actually published it while trying to troubleshoot the issue: https://www.instructables.com/id/Zeta-Reticuli-MIDI-controlled-10-band-EQ-and-mult/

0
None
RedBinary

5 years ago

I'm including the offensive image. The Instructable editor now says "parsererror
SyntaxError: JSON.parse: bad control character in string literal
" I'm curious if that naughty char is the apostrophe in "wouldn't" in one of the tags. A bit disappointing that I can't edit the instructable at all now.

stain02.jpg
0
None
canucksgirlRedBinary

Reply 5 years ago

Well you wouldn't be able to delete the image as long as its attached somewhere. Did you try and edit the tag? From your YOU page, go to Image Library (below your user image) and from the page that loads, click on the "your library" tab. Find the image and click on the orange text below it so that it opens up (showing you the image and the different sizes, etc). On the left, near the bottom of the column is the "Keywords". Click on the icon to delete the keywords and then add keywords WITHOUT any additional characters. Then try and open your draft.

Let me know what happens.

0
None
RedBinarycanucksgirl

Reply 5 years ago

Well I had gone to the same "image library" previously, but somehow failed to get to the view of the image that I'm at now. Unfortunately there are no keywords. It is in the "image notes"

0
None
canucksgirlRedBinary

Reply 5 years ago

Oh... my apologies. I misunderstood when you said "tags". Yes... that is a problem now. If the use of non-conforming characters are on image notes, then there is absolutely nothing you can do to fix this.

Today is Thanksgiving, so you have 2 options. The first is send an email to info@instructables.com and ask them to delete the image from the draft (or just remove the image notes). Being a holiday, they may not get to it until next week.

Your other option is start over with a new Instructable (I know)... And this time, don't use the same image. Upload a new one and ensure that no other characters are used in the notes. If you get it working and published, then you can send an email asking that they just delete the other draft.

Unfortunately, I don't see any other option.

0
None
RedBinaryRedBinary

Reply 5 years ago

In fact, looking at this tag here I can actually see the apostrophe. On the Instructable the tag does not display the apostrophe in the tag. (over the lighter piece of wood in the upper left)

0
None
RedBinaryRedBinary

Reply 5 years ago

?!? Now the apostrophe isn't showing up in the tag above again.

0
None
RedBinaryRedBinary

Reply 5 years ago

Somebody forgot to strip magic characters somewhere.

0
None
RedBinary

5 years ago

Here's the view from the Image Library. You can see the apostrophe in the Image Notes

image_notes.png
0
None
RedBinaryRedBinary

Reply 5 years ago

Is there a way to edit those strings from here that I'm missing?

0
None
canucksgirl

5 years ago

You were editing your image tags? Can you try opening your Image Library from your YOU page, and see if you can't fix whatever error was caused and then try re-opening your draft?

0
None
RedBinarycanucksgirl

Reply 5 years ago

That allowed me to identify the offending image, but if I try to edit it I get the same error. I tried to delete it from the ME page image library and it tells me that it's in use so I can't delete it. When I went to try to delete it from the Instructable itself it has now moved to the very top of the first step & due to the error I can't edit the Instructable at all now.