78Views17Replies

Author Options:

Using bold automatically inserts spaces Answered

I did a quick search and didn't see anything, so my apologies if this has already been reported:


I am finding whenever I use bold to highlight words in my documents, an empty space is getting automatically inserted at the end of the word.

For example, if I end this sentence with a word in bold and the turn off bold before using the period, there will end up being a space between the last word and the period which I did not put there and can not remove.

Discussions

0
None
kelseymh

7 years ago

What browser are you using? If IE does the same "clever" things which Micros**t Word, when you try to highlight a word, it'll force you to include the trailing space.

As an alternative, you can also use the (undocumented :-( ) keyboard shortcuts instead of highlighting with the mouse. Hit Ctrl-B (or Cmd-B on a Mac), then type the word(s) you want in bold, then hit Ctrl-B again when you're done. That will guarantee that only the characters you intend to be bold will be.

0
None
puzzleboxkelseymh

Reply 7 years ago

Software:

OS: Fedora 14 (latest versions of all packages)
Browser: Firefox 3.6.13
Plugins: No Script is installed but instructables.com is permitted. Adblock Pro is also running, as well as Lazarus. Can't think of anything else which might affect the text field.

FWIW I was using the keyboard shortcuts for the bold settings.

While in the editor, everything looks fine. Its as soon as I save that the spaces get inserted.

You can see it throughout this Instructable I submitted earlier today:

https://www.instructables.com/id/Brain-Controlled-RC-Helicopter/


Cheers

0
None
kelseymhpuzzlebox

Reply 7 years ago

This is weird. I looked at that I'ble, and it's obvious what's causing the extra spaces (see my earlier reply); the same effect may be seen in the topic text here, as well. I just created (and deleted) a forum topic of my own (MacOSX 10.5.8, FF 3.6.12), and do not see the trailing whitespace. I don't know whether Matt and Rachel are going to be able to troubleshoot this, if it's not reproducible.

0
None
kelseymhpuzzlebox

Reply 7 years ago

Ah, hah! Very weird. Using "View Source" makes the cause of this problem obvious, and it must be a bug on the I'bles server side. The HTML which is generated has a carriage return after each </strong> ending tag. A carriage return is (properly) interpreted as whitespace, leading to the weird behaviour you report.

0
None
StumpChunkmankelseymh

Reply 7 years ago

Nice! Thanks Kelseymh! I never knew Word gave you bonus freebie spaces when you highlighted and added attributes to text. That's useful to know!

0
None
kelseymhStumpChunkman

Reply 7 years ago

It pisses me off. If I try to highlight part of a word, the d**ned thing will automagically cover the whole thing, and either the leading or trailing space (apparently depending on whether the time of day is odd or even). Did I mention that I hate Micros**t?

0
None
StumpChunkmankelseymh

Reply 7 years ago

I'm sorry to laugh at your pain...but I really can't help it. This is why I have Ubuntu with open office (best purchase I've never made). I don't turn on the windows machine unless I really need to. The mac goes on a little more often, but only because I have the Photoshop suite on it (Gimp just doesn't quite live up to my standards yet).

0
None
Lithium RainStumpChunkman

Reply 7 years ago

Purchase Linux? Ur doin it rong. :p

(What, did you pay for tech support...or are you pointing out that it's free? :D )

0
None
kelseymhStumpChunkman

Reply 7 years ago

The only times I use Fn Word is when someone else has sent me a document, or a form, which I need to modify. Otherwise, I use Emacs. I have a proper Unix (FreeBSD) system on my laptop (MacOSX 10.5.8), so I can use real applications :-)

0
None
Kitemankelseymh

Reply 7 years ago

I have WIndows XP, but only because it was already installed on the PC when I bought it, and I can't be bothered to change it.

I use Open Office, and only save documents in Word format because the idiot machines at school won't recognise them otherwise.

0
None
kelseymhStumpChunkman

Reply 7 years ago

Matt, please follow up on this. See the OP's followup to me -- in forum topics and I'bles steps, the Rich Editor appears to put a carriage return immediately after closing tags.

I am now testing it myself, using the Rich Editor for this paragraph.  Everything looks fine while I type it.  If I'm right, there should be extra spaces in the first sentence when I post.

0
None
Kiteman

7 years ago

Testing.

0
None
KitemanKiteman

Reply 7 years ago


Maybe I can reproduce it with the Rich Editor?

0
None
KitemanKiteman

Reply 7 years ago

Nope.

What software are you using?

0
None
StumpChunkmanKiteman

Reply 7 years ago

That seems really awkward. I'm not sure why that would happen. Though it doesn't seem to happen in Firefox on Ubuntu.