Author Options:

Video not embedding Answered

Just haven't been able to embed my youtube video into my instructable.
  1. I tried the using the embed tool
  2. i tried to copy/paste the youtube URL
just can't figure it out.



So just to help anyone else, the fix for this is: 1st get your video source from youtube by using the embed function their. 2nd In your instructable when in edit mode do not use the "embed video" function, rather click on "source" scroll down to where you want it on the page and paste it there. 3rd Hit save. All should work perfectly, thanks for all the help from the rest of you!

One note: The Source button is an "extended attribute," and is only available to paid ("pro") members. This bug still needs to be fixed, but it sounds like it's a Firefox bug, rather than Instructables, unfortunately.

Oh, that it is interesting in regards to the source option is only available to PRO members! This should be fixed asap, wonder if going back to an older version of Firefox, or just re-opening in ech, explorer would alleviate this for non-pro members.

So this seems to be a bug in the latest version of Firefox. We'll see if we can figure out a work around for it until Mozilla fixes it.



It must have been in both 3.6.9 and 3.6.10, then. I'm still using the former and was able to reproduce the problem.

kelseymh, thank you, pasting it into the source worked just as you said it would. Still not sure why the embed video function did not work, but ah well its all good now!

That wasn't me, that was Shadowman39. I don't like to suggest things which are limited to paid members :-) As for why the "embed" is broken, Cloude says it's a bug in the latest Firefox.

Weird. I just visited the first video in your list and copied the embed codes into the "Rich Editor's" video popup box:
Flash Animation

In the editor box, I see immediately above a big box with a red <b>FLASH</b> in the middle, as you described in your previously posted Question.  When I use the <b>preview</b> link, there's just a big gap.  Let's see what happens when I actually post...
Okay, there's nothing there. I notice that the URL has a qualifier. I'm trying to embed again, this time using an unqualified URL (http://www.youtube.com/watch?v=brvqgpBtCr8)

Flash Animation

Using the embed button didn't work in my Ible either, so I went to the HTML editor (source button) and pasted the embed code there, and it worked fine.

The answers you've already received didn't help? In particular, the fact that you got a red "Flash" square means that you were successful. Did you view your I'ble after doing that, or not?

Yes, I did view it after, and on another computer. Sadly no video, though if you run your mouse over the screen to select all the area where the video should be is a large highlighted square. I published another video and there wasn't an issue before. I'm stumped

I'm stumped as well. See my two posts above; I get the same behaviour as you do. Either there's something evil in your particular video :-), or perhaps YouTube changed something overnight which is introducing bugs into the embed-code they generate.