Author Options:

Windows 7 Setup error:Windows setup could not configure one or more system components.? Answered

Hey, I am trying to install Windows 7 RTM, legally, Have my legal product key with me.

So it installs, i have the ISO image, i mount it, and run the setup from there, that is how i did it with the windows 7 RC, And it worked fine.
But now, It gets past the first part, installs fine, Second part, Fine, 3rd part where it is at "Completing installation", At about 99% done, It gives the the following error:
Windows setup could not configure one or more system components.
Then it restarts, and ends there.

I tried re-downloading twice, I tried Re-installing 4 times, No avail.

Any help? Ideas?


try to disconect any usb hard disk,stick,pendrive,wifi adaptor.
then burn the rtm to a dvd,make sure that will be bootable and then boot from there.
i hope i helped.


8 years ago

LOL!!! u should've got a Mac! LOL

You sir Fail, I tried installing Mac os on a mac, and it is by far way more tedious that installing Windows on a PC

its not hard, just install, enter a few bits of info, then wait under an hour. its easy!
You sir, have no sense in how to install any software! 'FAIL

You fail for running away.

That is how it is for windows too, Especially for the newer OS's
enter a few bits of info
I wish it was like that, When i tried to install, the Un-predictable Mac OS did not find the hardrive, or any partitions.
Tell me, Which os is not a rip from a free os?(windows, mac os ripped the unix core, AND made it closed source)

Try burning the image and running it bootable instead of installing from within the operating system?

Oh jeez...I had no idea Recreate was doing the install off his harddrive. I didn't think that was possible with any flavor of Windows 7, RC or otherwise... Now I have to ask, how do you do it with RC?

Also, any OS newer than XP can do that.

ah...newer than XP...rats...I need a new DVD writer then (the old one is no longer burning any apps outside coasterware)

I mounted the Disk image, And installed it, Windows 7 RC installs completely with in windows.(and i RTM does too, but something went wrong.)

That is what i will do today. Thanks!

I'd consider running the WIndows7 upgrade test app to see what components might be giving you problems and resolve any flagged issues prior to doing the W7 install. I assume (hope) you're doing a secondary install to another partition on an already working XP/Vista system?

1: I already did that 2:Yes, it has XP and another OS installed, i have a partition ready for it.

Crud. Are you upgrading the RC installation or doing a completely fresh install?

Doing a fresh install on another partition.

Hmm. Are you performing the install with all external devices and usb devices disabled?

I don't see how i could disable them...

I saw a note in a windows 7 forum in which someone said that was something to do when installing 7. idk why.

related link

*sigh* that is an entierley different error message...at a different part...*cries*

Sorry, it was the best I could offer.

It looks like there is a driver or two that it does not have and it is for a part of the computer that is necessary for windows to run. This could be and probably is something on the motherboard.

But the windows 7 Release Candidate Worked perfectly!