6035Views7Replies

Author Options:

Windows diagnostic policy is not running? Help connecting to the internet. Answered

HI, this is probably not the right place to ask this question but i will give it a shot anyway.

I was using my computer recently and then without any warning, it decided that t would not connect to the internet. The connection status says 'limited connection'. Whenever I try to troubleshoot problems it says that the Diagnostics Policy Service is not running. I have set them to automatic, after restarting, When I try and start it it says "Error 5: Access is denied." I have tried to run a system file checker but there are no problems that come up.

Thanks, any help is much appreciated.

Discussions

0
None
Vyger

Best Answer 4 years ago

You probably have a virus. I dealt with one like this a little while ago. Among other things it changes the permissions so you aren't allowed to do anything even though you are the administrator. It also turns off various services. Best thing to do is pull the hard drive and use another computer with up to date antivirus software to scan the drive and find the virus. After it is clean you will need to repair the damage to the system.

Ok, thanks. I have run a virus checker on it. But the virus might have disabled my virus protection. I will try scanning it from a external hdd enclosure.

No luck so far, any other ideas?

I had to backup the data and run system restore, works fine now. Thanks everyone.

Have you checked you tried turning your modem and router off and back on again?