Author Options:

anyone know whats wrong here? Answered

i got a toshiba tecra s10, but it isnt turning on.
it doesnt run on battery (i dont know if its dead or what) and if i plug it on the charger all it does is flash the charging light.

does anyone know what this means and how to fix it if i can?



Best Answer 7 years ago

After reading the posts I think I get the idea as to what is going on.
It is possible that it is the motherboard. Specifically there is a chip, like a relay that tells the MB to power up when the power button is pressed. If that has become defective then the MB does not get the turn on signal. I have seen this in desktop machines, everything is fine, the power supply turns on and tests good but the board refuses to kick on. Sometime they will do this intermittently, sometimes start sometimes not then for no apparent reason, start. You might be able to kick start it by removing the battery and also any internal CMOS battery. Actually if you can find it, and it has one, replace the CMOS battery. This could be the problem and it might finally wake it up. Even though the CMOS is now flash memory and does not require power to maintain the data it still does need a battery to keep the clock going. Some of these BIOS will not work correctly if the CMOS battery is dead. Or it could be a bad chip and just never start.

yea, ive read about the cmos battery "reviving" laptops before, but that chip, i can honestly say i never have. that some info i'll have to remember.

but im thinking it could be the universal charger, the laptop charge light is green, and its flashing, the charger DOESNT supply the right amps and maybe the laptop is trying to do somethng but the inadequate charger isnt letting it. im gonna see if i can find a charger locally or on dealextreme, i realy want this laptop to boot.

i dont know if wny of you guys want to hear it (considering this is a diy site and this would have made one hell of an ible if it was working) but i sold the bulk of the laptop for $25, excluding the ram and wifi card.

but now i realized i accidentaly left the bluetooth module in there. i feel so stupid, i was gonna use it with my gateway.

I had a friend with a toshiba laptop, it worked no battery until it died, but wouldn't charge. If you say it won't work with no battery, it is probably the charger, try ebay for a new one. But if it's anything like my friends, it still won't work. It sounds like the same problem, it flashed but wouldn't turn on fully. I actually took it apart to have a look, and the adapter was fine, and I checked the power supply with a multimeter and it was providing the right voltage, which suggests something on the motherboard has died. I never did get it working in the end, so he sold it for spares and bought a new one. I have a feeling it was the non-genuine charger though. It was providing the right power, but it might need to be genuine. I had a similar problem with a motorola phone, it had a USB port for charging, so I built a USB 5v battery charger, and it worked on my phone that uses usb for charging, but it turns out it needed a genuine motorola adapter that sends a pulse to initiate charging.

this is what i was looking for.

i know the original adapter supplies 15v @ 5A, which my universal brick may be unable to supply, and perhaps there is something special about the genuine charger that it does different than generic ones.

im still not sure if i want to go out and buy a new charger yet, i think im going to contact toshiba and ask them whats up here and see what they tell me.

Yea, I know laptop power supplies can be very expensive, so I would contact Toshiba first to confirm this is the problem.

yea unfortunately they dont have live chat and the forums arent helping much..

Here are two places that sell desktop supplies.
There are others you may know.  They are always changing their lineup.


there are a few websites that have a pdf file that shows you how to strip a laptop down. get one of those, you'll need it.

power comes in these areas: your mains supply - that's fine i assume. then the transformer - check that out. then the actual jack power input as that is the most common fault (excepting apple macs as that has a magnetic plug). then if all is well, check out the power board within the laptop itself. also check out fuses where they occur.

it would be possible to do a blow-by-blow account but that would need a more hands-on approach. why not do an online project of photos and have our members help you step-by-step?

haha beilieve me, ive stripped down 7 laptops already, i dont really need a manual to tell me how :P

are you saying i should start a forum topic here where people can help me figure this out?
like i said, i havent got the original power supply, im using a universal one, but t changes its voltage according to what the laptop asks for, but not the current, im sure its proprietary to the voltage, in which case that might be the problem here, but its difficult to pinpoint a problem when you dont know where it started...

Apologies - I took your query at a much more basic level from your question. ;-)

If you believe the psu is at fault, a new one can be had for pocket money:



However, if you're still wanting to trouble-shoot, perhaps a data-logging recording multimeter might show your thoughts to be correct? Either way, I wish you well, it's a problem I enjoy having to solve! ;-)

i looked on dealextreme and i have come across a toshiba branded charger (i dont know if its actually toshiba but w/e) it supplies the correct values and is supposed to be compatible with this laptop.
im not sure if i should trust it though because it costs about $12 CDN but i might take my chances anyway.

i really hope this laptop works, because even though its a BEAST, its got that swappable graphics card, which for $0, is TOTALLY WORTH IT. plus my adorable little gateway isnt even 100% capable of 64-bit windows 7. i know the toshiba is because i got my 4gb of ram from it anyways.


7 years ago

I have had several lap tops with dead battery syndrome ( Batt is nearly shorted ).
Try taking the battery out and run it on the charger.
If it runs you need a new battery, if not something else is wrong ( like the charger )


ive tried it without the battery and no dice. its a universal charger, so that may be the problem, but the laptop still refuses to boot even after a static discharge.
i dont exactly want to go out and buy a new adapter if the laptop might not even work, but ive got a feeling its the adapter and (hopefully) thats all thats wrong with it, but finding 15v @ 5a is gonna be difficult.