Author Options:

avrdude: stk500_getsync(): not in sync: resp=0x00 error on Arduino? Answered

I am trying to load some code onto an Arduino Uno. So far I have tried checking to board to make sure it is is right one, unplugging and re-plugging, checking to be sure it's the right COM port (3 in my case), Pressing the restart button before, after, and during the uploading process, updating the FTDI drivers, re-installing the drivers, and re-installing the most recent Arduino software. I have tried pretty much everything I could find on Google when I googled the error. When I try to install the little orange L button blinks as well as the RX led. The green led is on, and resetting makes the L led blink some more.



Best Answer 5 years ago


According to that it's nonspecific, it just means the arduino is not responding to requests to program. For me this meant I'd fried the bootloader on my duino.

Check out how to reprogram (burn) the bootloader with either a usb-isp cable, or with ANOTHER arduino as programmer. This rewrites the base code to the duino through SPI, not the standard usb-ttl connection. If reburning the bootloader doesn't work, then you may need a new AtMega chip (thankfully only a few dollars).

I'm having the same problem. How am I supposed to know what COM port I'm using? Only two show up and neither one lets me sync.

When you plug in one of them will appear, when you unplug, one of them should disappear; the one that appears and disappears is the arduino board.

If it doesn't change (you may need to pull up the menu before/after each plug attempt) you can try using device manager to see if/when it pops up.

OK, so I re-downloaded the boot-loader (Which was really fun, by the way, to actually run a program through command prompt) and it still isn't taking any programs using. Hmmmm. Time for a new AtMega...

:( that's no good. at least the new chip is pretty cheap. Strange you had to use command line - the arduino IDE has a burn bootloader option built in.

I used the command line mainly because I wanted to try out WinAVR. Just so I am familiar with it in-case I want to install a custom bootloader. Also when I tried the burn bootloader though the arduino IDE it gave my that very same "avrdude: stk500_getsync(): not in sync: resp=0X00" error, so I decided on a roundabout approach, which ended up not working either.

Try to upload it selecting Arduino Uno in the board manager. I had the same trouble, and we get to solve it like this. We think that the manufacturer might have soldered an ATMega 328 with the Arduino Uno boot loader.

avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x93??

I was just having this problem with an arduino micro pro and DFRobot FTDI. I noticed that the Pins are not in the same order. They don't match up quite right so you should use jumper cables to match them up correctly. This may not be the case for all FTDI up loaders so be sure to read how the pins are labeled on yours.

On my FTDI board it will be GND, CTS, VCC,RXI, TX0, DTR.

On the Arduino the pins are BLK, GND, VCC, RXI, TX0, GRN.

To get rid of the avrdude not in sync error switch the first two pins so that CTS goes to BLK, and GND goes to GND. After I did this it worked.

I looked up other models of FTDI uploaders and some of them had TX0 and RX1 reversed.

Just read the pin out labels carefully.


4 years ago

I had the same problem when an ITead bluetooth shield was on the arduino uno.

The solution was to switch to 'to ft232' from 'to board'

Don't forget to switch back to to board after uploading!

Could you please explain what you mean? What do do I need to switch?


3 years ago

it could be also that u are running a program that tries to push a lot of data trough serial which gets buffered and messes up the communication, keeping the arduino reset until the right time manually helps in this case

you are probably right..the problem is I tried different timing or this reset push, all did not work. I even followed one on youtube exactly; still not working...such a problem.

I just experienced this problem and found it was caused by something else (a GPS module) communicating on the same RX port (digital 1) that the computer uses to receive upload confirmation from the Arduino.


4 years ago

Had same issue but was fine once I took out the connections in both the digital 0 and 1 (TX/RX) pins. So disconnect stuff from those pins, connect and load sketch, disconnect and re-connect pins, then power and run.

This is very much like Italian cars..great cars except some mood-killing glitches that makes you want to throw them in the next river...I have 2 Arduino Pro mini; and 3 USB loaders...I tried all the tricks on youtube and arduino.cc...but nothing works...I tried: remove the TX pin before loading...did not work...tried press reset button (between compile and load, before and after...all possibilities...nothing worked...) tried a capacitor to DTR...and DTR to DTR...nothing worked...Anyone please help...

Sir i unable to program my atmgea2560, i tried using all methods, i have choosen correct COM port ,Board,and arduino as isp,changed usb cables,tind the error "" avrdude: stk500_getsync(): not in sync: resp=0x00 solution"" please help me out

i also wasted half an hour on this silly issue not being able to upload a sketch to the arduino uno. eventually i took out the pin on RX and then it could upload without problem.

hello atoms ....

i had the same problem, resp 0x00 corresponds to null response,
ie, the UNO chip wasnt able to communicate with the COM port of the computer..

While the Arduino is plugged in the USB port Go to device manager and under com ports choose the one. Uninstall it.

Replug the Arduino device and let the Unsuccessful driver installation arrive. Click cancel.

Go to Arduino installation directory, go to drivers, choose ur board corresponding '.inf' file and copy it in a folder in ur desktop.

Device manager again. Update driver software for the corresponding COM port, choose from desktop the saved '.inf' file. Lets installation complete. Upload ur sketch, hoorah __ go make the world a better place to live in.

Peace Atoms,

I got this error when I tried to upload a sketch while there is something connected to the default RX pin...removing the connection on the RX pin made me able to upload a sketch again without the error.

The main problem occurs during the Com port selection. the arduino is very port specific. it will always give problems with Bluetooth devices.
I had the same problem and this is how i solved it.
- press the reset button.
- disconnect the device.
- open device manager.
- go to com ports.
- connect the device. (device will appear e.g arduino r3 etc), check the port.
- open arduino console and check whether they are the same ports or not.
- if same and still giving the error go to device manager select a different port , try till you succeed.


I'm also facing the same problem and 've tried your solutions. But, only one com port could be found. Thus, my problem still exists. How can I do now? Thank you!


I have the same problem too. I am using Windows 8 and I have he correct connections, board selected and serial port selected, but device manager doesn't recognize my Arduino Uno R3. I can't update the drivers because the ones on my computer are upgraded to full. (Sounds Lame) And no browsing can find Arduino Drivers, because the Arduino is unrecognizable, so it provides no driver updates or any other information. Please help!


Hey guys I had the same problem but then I noticed under tools that it was referencing the wrong board. It was referencing the UNO instead of the PRO-Mini and that fixed it. Well I also had to find the right comport under tools as well. And that officially fixed it. Hope this helps.

Frollard's right: you've somehow corrupted the bootloader.

Have the same problem. Have done nothing with UNO other than testing a pair of USBasp programmers. Two months ago I purchased several ATmega328P's from Mouser. The chip in my UNO was a ATmega328 and this caused the problem with device signature which I resolved with an edit of the avrdude.conf file, and changeing the ID's 14 with 0F etc. I've tried swapping ATmega328's and still get this same error message. Iim currently using using the USBamp to upload my sketches okay, but that limits me from use of the serial monitor which I need. If the bootloader was corrupt swapping 328's should have fixed that problem but didn't. I see RX data comming to my UNO but no Tx leaving. Any suggestions?