215Views16Replies

Author Options:

eBook downloads in Firefox 4, 5, 6, AND 7 Answered

I am hoping I am not the only one with this issue:

The new ebook downloads are currently very difficult to download in Firefox here.
In Firefox 4-6, the links that should show up are covered almost completely by the text box above them, leaving a two pixel high sliver that can be clicked on.

This makes it very hard to download the ebooks in Firefox.

In Firefox 7, the buttons are mostly covered. You cannot read the text, but you can at least tell the buttons are there, as a 10 pixel high orange stripe appears.

The links work normally in other browsers I have installed (Iron, Opera), as well in Firefox 3.6.x (confirmed from another user's computer).

I've attached a screenshot that exemplifies this issue.

For reference, I'm doing this on Windows 7 x86, SP1. Display resolutions are 1600x900 pixels for secondary, 1900x1080 pixels for primary. 96 DPI - nothing strange here.
I have gone as far as reinstalling the operating system, with no change.
I also have a Linux machine running Firefox 7, on which I cannot replicate this issue, even with the same set of add-ons installed to it.

On Windows: Current browser: Mozilla/5.0 (Windows NT 6.1; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
On Linux: Current browser: Mozilla/5.0 (X11; Linux i686; rv:7.0.1) Gecko/20100101 Firefox/7.0.1

Update: This issue has persisted for four full versions of Firefox, and STILL hasn't been addressed by staff.
This is why I let my Pro subscription lapse, and don't want to renew it.

Discussions

0
None
Xial

7 years ago

Updated this with more recent information and additional troubleshooting.
Maybe, just maybe, it'll get looked at with the new data added.

0
None
omniwolf

7 years ago

Hey I guys, I think this is a layout problem on the part of the site. If you have firebug on firefox you can make the format buttons visible by tweaking the height of the div called "format-buttons"

height: 50px
works for me and makes the download buttons slide out from under the summary text box. You do still need to be a pro member to download but at least you can now see the buttons.

0
None
ballardbk

7 years ago

I have the same problem, whether using Firefox 4, IE9, or Chrome. Screen resolution 1680 x 1050. I sent a message to support, which sent an auto e-mail directing me here.

It seems that once the started charging for "pro" services, I have had more and more problems as a "free" user.

0
None
ballardbkballardbk

Reply 7 years ago

I tried suggestions of disabling and re-enabling java. Did not work. Tried suggestion of changing screen resolution, clearing cache, and changing font size, still did not work. This has been an issue for almost a month with the new versions of IE and Firefox for Windows.

0
None
ballardbkballardbk

Reply 7 years ago

It works from my tablet with the built in android browser. Yet, e-books are only available to pro members. Thanks for excluding those who may not be able to afford pro-membership, no matter how little it costs.

0
None
rickharris

7 years ago

others are reporting this - is anything being done??

(or is this BUGS thread a waste of time?)

0
None
Kitemanrickharris

Reply 7 years ago

The team development team is very small, and presumably have to prioritise problems - if a problem is urgent, use the "service@" email address.

0
None
rickharrisKiteman

Reply 7 years ago

Not urgent just some acknowledgement that a fairly important issue is present (assuming they want people to download the E books.).

I will stop bumping it up the list!

0
None
Kitemanrickharris

Reply 7 years ago

They tend only to comment when the problem is fixed, or they need more data (see Stumpchunkman's posts, for instance).

0
None
NachoMahmaKiteman

Reply 7 years ago

. Ie, unless they need more info, you are left to wave in the breeze.

0
None
rickharris

7 years ago

Bump still no response!

0
None
rickharris

7 years ago

Bump - Determined to get a reply to this.

0
None
rickharris

7 years ago

I wonder if anyone ever reads these posts?

0
None
rickharris

7 years ago

Same for me too.

0
None
Burf

7 years ago

Try reducing the font size in your browser and see if that helps.

0
None
XialBurf

Reply 7 years ago

Sorry, but that has no effect here.

Of note, I'm on default settings for Firefox 4.

(Interesting that I didn't get the notification for this message until two hours ago...)