Author Options:

iPad App bug. The most irritating one. Please solve. Arrgh Answered

I'm using the app on the iPad. Mine is an iPad Air 2, and the OS is 8.4 version. Whenever you try to click on the 'explore' dropdown on the top the app exits (don't know If it crashes. It just exits and I come to the home screen). It is the most irritating thing ever.

I tried this when I'm Logged in, the app exits and logs me out as well. When I'm logged out, the app exits. This happens as soon as you touch the explore dropdown on the top bar. Please please fix it. It screws up the entire experience. 

i can't really give you any screen shots since there is non error message. 


I'm sorry to hear you're having a frustrating experience with the iOS app. Unfortunately, we can't offer a fix for either the iOS or Android Native apps, as it's no longer possible for us to release updates to either one. All of the behavior offered by the native apps -- including mobile web authoring and photo upload -- is now offered by our Mobile website (https://m.instructables.com), and that's where we're currently allocating engineering resources. Though the apps worked a year ago when these versions were released, keeping the apps working smoothly requires a dedication of constant resources to fight deprecations and changes in Apple's and Android's environments.

We loved building the apps, but since most people encounter Instructables first through search, we wanted to dedicate resources to our mobile platforms. Giving our full attention to desktop, mobile web, and two dedicated mobile apps is not feasible for a team of our size. We do believe that many users are still using the apps successfully, so we have not pulled them from their respective app stores. Development on the apps has been discontinued, however, so unfortunately there's nothing we can do to help the specific issues that may be encountered.

We're excited to have you all as a part of the Instructables community. I wish I could deliver more promising news on the apps, but I wanted to at least share some of the decisions that have resulted in less-awesome experiences for native app users.

Thanks for letting us know you've given up on it - deleted (2 forum posts and an email to service@ couldn't shake loose this info). I checked out the mobile site on Safari and it indeed seems to have the same functionality (hopefully without the bugs). However - at least when using Chrome on my phone (iphone6+), it goes to the desktop site, and entering the m.instructables URL doesn't help - it defaults back again. Is there a way of making the mobile version work on Chrome? Interestingly, if you force Safari to go to the desktop site, it works for that particular URL but not any subsequent clicks.

Anyway, good to know that I can use Safari to upload photos with my phone... and it didn't delete anything. Weirdly though, it rotates all portrait images to landscape. Doubtless you're working on that, because I can't see any way to fix that in the mobile browser.

Terrific information here, thanks for the reports. We'll take a look at the user-agent for Chrome on iOS. iPhones should see the mobile site of course, though user-agent detection is more art than science.

Are you using an ad- or cookie-blocker in Chrome? We set a cookie to record your preference for the desktop site, so if the cookie is not accepted you'd only see one mobile page.

And yes, we're definitely looking into mal-rotation issues. Thanks for checking in there!

No blockers on iOS Chrome. Not bothered particularly by this limitation - I can now essentially treat Safari as the Instructables app - but it's entirely possible that lots of people that you assume know can upload photos directly from their phone actually don't know that, and are instead doing it in an unnecessarily laborious way. Like me until today.

We recently improved our Mobile detection mechanism and observed that some cases like yours (iPhone 6 + Chrome) seem to work now.

I'm attaching a screenshot of what you should see in the mobile website for reference, in case that's not what you're seeing please let us know.

Our tests were based on what is claimed by Chrome to be the User-Agent on iPhones :



seems unchanged. Note I don't seem to be able to unrequest the desktop vers


Interesting. If you can send me what you find here :


I'll be able to investigate further. If you don't feel comfortable posting here I'll send you my e-mail by PM.

Makendo, Indeed your User-Agent will lead you to the Desktop website. But looking closer at it, it actually looks like a MacBook UA, this "UA tester" agrees with it :


"This is a computer. Your UA is Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_4) AppleWebKit/600.7.12 (KHT ML, like Gecko) Version/8.0.7 Safari/600.7.12 (000248)"

Usually iPhones explicitly mention "iPhone" in the User-Agent, which is how we direct you to the right place. I have the impression that your Chrome is using some sort of "cloaking" and using a Desktop UA. Please review your settings as some major browsers do have this feature for the mobile versions.

You can confirm that this is happening by going to the same website (demo.mobiledetect.net) with your Safari Browser and checking that it confirms you're in a phone.

Unfortunately if your Chrome is sending this UA to the websites you visit from your phone, there's not much we can do but I'm glad that we were able to diagnose the problem. Good luck!

for future reference- I fixed it by going settings > content settings > auto detect encoding. Can't recall ever changing that so maybe it is switched off by def

I'm glad you were able to find a fix, thanks for letting us know. Enjoy Instructables!

I'm using a Note 5 with Chrome browser and whether I type the mobile address or click mobile website link I still get the desktop version. I've checked all settings and cleared cookies and it still does it. This is why I used the Instructables app and even then not everything works on the app correctly anymore.

the problem I have is when I try to login through the app, it takes me to the instructables login site on Safari. I click the button to login thru Facebook. Previously this would log me in and take me back to the app... Now it logs me in and keeps me in Safari. If I manually switch over to the app, I am not logged in. Smh.


2 years ago

I have had the exact same problem for the past 6 months or so - it has completely ruined my experience with Instructables as the desktop version is just too clunky to use on the IPad. Can't understand why it hasn't been solved......do Instructables themselves monitor this forum?

Interestingly I had the exact same problem with the Facebook app for a month or so but then all of a sudden it worked again, probably after an update but I couldn't say for definite. No such luck with the Instructables app though. I also reported the issue a couple of times through the app but no response.....

i having the same on ipad 4 with ios7.

Yep, iPad mini also

In addition, where is the option to add an instructable to a collection from the iOS app? Or maybe there isn't one and I should stop looking. lol

I'm getting the same thing happen, whenever you hit explore app exits.im using an iPad Air

just downloaded this app and when I hit explore button it shuts down. Help?

same for me I'm using an iPad mini 2 iOS 8.4.1 and the explore button shuts down the app.

Please resolve soon =]

I am having similar issues and just came here to post about it, if I get the chance to before I get randomly logged out again.

With the app, I just tried to publish a new Instructable and it kept closing on me. That's the only issue I have noticed, since I don't use the app on my iPad much.

When I try to log in to the website on my iPad, as soon as I tap the box to type in my name, it takes me to the page advertising pro memberships. It sometimes does this over and over again, until I end up giving up because I can't log in. Then once I get logged in, I go to view an Instructable and I get the "there was a problem with this web page so it was reloaded" message, then I have to log in again, only to have it happen again....

All this just started happening a couple of weeks ago. I thought it might be my iPad but it isn't happening with any other sites.

Also, a little while ago, when I was loging in, there was an old version of the featured page showing. I'm sure it was old because there was one of my Instructables that was featured months ago on it.


2 years ago

Im having the same issue. IOS 8.4.1 iPad Air. This started in early Aug. I can't really associate any other change on the iPad with this error. I wonder if something changed on the server side?