185Views25Replies

Author Options:

instructable text, self deleting at random save steps. Answered

For a while now while I am working on an unpublished instructable the auto save function I believe is backfiring.  Instead of saving it actually deletes whole sections.  I thought oh well, I can always go to the history section and copy/paste or click revert.  To my horror it deletes the text from that step all the way back to step one, aaaaaaaaaaah.  I thought perhaps that this was isolated, to the one you might be working on.  Nope, when I opened a second one I had been working on, the intro has now been deleted.  Yes, including in the history as well....

Discussions

0
None
rachel

7 years ago

Hi all, this actually has been very trick to sort out and is basically requiring a rewrite of a large chunk of the auto-save and image uploading code. It *is* being worked on and I hope to have the fix out within another week or two. As you can imagine it requires a bunch of testing too -- we definitely do not want to push out something that is worse than the current state, and maybe kills the workarounds you've had to find.

0
None
iminthebathroom

7 years ago

yes, pretty much standard occurrence these days, must be tricky bug to work out. Have had it happen numerous time in the past week. The real urk for me these days is not being able to include comment on pictures these days. If I do any more then 2-3 comments in one instructable session I get an error message.

0
None
D00M99

7 years ago

ME TOO OMG ANNOYING

0
None
username252

7 years ago

This happened to me too. One time it removed everything written in the text. I went absolutely nuts, knowing that I had to start over.

For now on, I'll prewrite everything on Notebook & copy it.

0
None
sillyzombie666

7 years ago

i just lost 3 big steps to an instructable i've been working on for a month and the contest im putting it in ends tonight....... thanks alot

0
None

sometimes if you go into the history section of the one you are working on, you can see your old text, open another tab, and start up instructables, bring up your project. Then copy from the history & paste into your new one. I've discovered the best way around all this is to put your pictures in first, then add your text. If you do it the other way around it, that is when most of the errors occur. These days I upload all my pics first to one step. Then delete them from the instructable. The when you want to add the pictures instead of uploading them straight to your instructable step, you take the from the section where they have been uploaded to the site all ready. Kind of a goofy way around the bug, but it works. The copy paste thing from history doesn't work all the time though. Best to do all your major writing in a word type program, and then copy paste from there. If something gets deleted then you can always just copy paste it again.

0
None
dylyiminthebathroom

Reply 7 years ago

exactly what Ive experienced. sooooo annoying!!!!

0
None
killersquirel11

7 years ago

There's this firefox addon called lazarus if you want a decent workaround

0
None
jeff-o

7 years ago

This happens to me all the time. For me, it seems to happen when I'm adding and rearranging photos. I posted a bug report ages ago, but I guess it still hasn't been fixed.

For now, I save all the text in Evernote or Word before adding pictures. Then when the text inevitably disappears, I just copy it back in.

0
None
iminthebathroomjeff-o

Reply 7 years ago

Yes, I've been doing the paste copy from word. Had it happen again yesterday, I noticed its when i import a bunch of pictures into a page with wordage all ready.

0
None
iminthebathroom

7 years ago

spoken to others who have had the same problem recently

0
None
Biggsyiminthebathroom

Reply 7 years ago

I have had this happen once or twice... I always spot it on the first page of an I'ble, I have started opening one tab to edit an I'ble... and another one with the excisting version (one tab for each page) just incase it deletes again

0
None
Biggsyiminthebathroom

Reply 7 years ago

well... with that red bobble hat... I thought you were.... Now... lets go and get some face paints and doll you up like a tiger!

0
None
iminthebathroomBiggsy

Reply 7 years ago

The hat and shirt combo in the picture is when i went as a member of team Zissou from the movie Life Aquatic

0
None
scraptopower

7 years ago

I have this problem all the time - it's annoying, hope they can fix it! It often deletes the text when I add more images too.

0
None
StumpChunkman

7 years ago

I'm curious. Would you mind trying to make a new instructable, and then copy and pasting from one to the other, and seeing if that instructable has the same problem.

Also, is there a specific thing you're doing that triggers the deletion of text? Adding pictures/uploading pictures/adding a step/clicking to edit another step/clicking preview and then clicking back/ clicking preview and then clicking edit? I'm curious if there's one or two things that precedes the act of the text getting deleted? If we can figure out what that trigger is, we can fix it.

0
None
iminthebathroomStumpChunkman

Reply 7 years ago

I will for sure. Usually when I create a new instructable I add and title all the steps first. In a desktop file I have all the photos organized in sections. These are then added to each step. Then i go back, following the pictures writing in the text. Occasionally going back to edit after spotting something in preview mode. Often when this happens, the animated save icon will take an extraordinarily long time to save. Ironically usually it is the step previous to the one I just saved that seems to get deleted. Anyway, I'll create the new one over the next day or two and post the results. I'll date stamp and record the exact URL at the time of any discrepancies that i notice.

0
None

Created the clone via copy paste. I did not upload pics though this time, I used the ones from the "previously uploaded section of instructables". Add text to all steps, including the ones where text has been deleted, to act as a marker.

https://www.instructables.com/id/E7N32M3GJPJE6RM/

so far no problems though, any backdoor kung-fu you wish to try, go right ahead!

0
None
iminthebathroom

7 years ago

Here is the URL from when I asked the question int he answers section, guess others have had similar issues.

https://www.instructables.com/answers/Has-anyone-else-noticed-they-are-losing-data-from-/

0
None
LoneWolf

7 years ago

I just have to say, that is one terribly long title =)

0
None
iminthebathroomLoneWolf

Reply 7 years ago

Oh, haha, yep i was leaving it like that just for today, kinda of an inside joke - got busy and forgot about it