Author Options:

laptop usb doesn't work anymore.? Answered

My friend has an Asus x52j laptop with win7 on it.
Yesterday he shut it down and removed his  external mouse just before the power went out.
when he put the power back on, the system checked the disk integrity on all his 3 hard drives, then rebooted, and then he tried to log on but there was no mouse cursor on the screen and the  keyboard did not work.
any suggestions?
also this is the only computer he has access to.



Best Answer 6 years ago

It sounds like the motherboard drivers might have gone bad... (I'm just guessing here)
That happens when you remove USB devices without "Safely Removing" them or "Un-mounting" them.

To fix this, consult the motherboard manufacture's website, and update the drivers for the motherboard, and flash the BIOS. Hopefully that should clear it up.

When you say you went to boot setup it worked... what are you referring to? The keyboard?

If the above doesn't work, then you might have a problem with the system. To troubleshoot, download a free system such as Ubuntu or Knoppix that can be run off of a CD (You don't have to install it on your computer). If it works in another system, then you know that there is a problem with the system itself, and the easiest way to fix it is to reinstall the system.

Let me know if you have any new info, or if what I suggested doesn't work. It sounds as if you don't have access to another computer to help your friend... but have you considered the local library? Most libraries have computers that you can use. I don't think you are going to find a way to fix it without access to another computer. You are almost certainly going to have to download something. Also, make sure the CD drive works... otherwise you are going to have a tough time even getting anything you downloaded on to the computer.

Good luck! :)


Answer 6 years ago

my friend took the computer back to the store and a guy fixed it there but i still will mark you best answer because you gave the best solution to this type of problems :)


6 years ago

Disconnect the battery and all the power, leave it for a couple of minutes, and try again.


Answer 6 years ago

we tried but it does not work.
we also tried going into the boot setup and curiously it worked.