Why cant i post my instructable?

So i have about 10 finished ibles saved as drafts, and today ive been wanting to post at least one of them since there are a few applicable contests running. So i went into edit and clicked publish, it took me to screen where you have to add channel, category, license keywords etc... I used  attribution noncommercial share-alike which is the default it automatically brings up, i clicked 'publish now!' and nothing happened, the url didnt change, there was no loading icon, nothing looked like it had changed at all. So i tried clicking the 'Yes, publish my instructables' at the bottom of the page and still nothing happened. I tried both entering and not entering the ible into 3 contests, but no luck. Ive tried 3 times today, ive turned my internet and computer off and on twice. I really have no idea whats going on, ive posted 28 ibles over the course of 3 years and i dont think ive had this trouble before. The main contests i need to enter all end in about 2 weeks and i have a ton of ibles i need to enter so if anyone could proivide an answer ASAP that would be great

There have been a few niggles with publishing I'bles following the change from HTTP to HTTPS last weekend. A few issues have been reported in the forums (see below) but these mostly seem to have been resolved.

First thing worth trying is to clear your web cache and cookies, see if that makes any difference.

https://www.instructables.com/community/Oops-We-co...

https://www.instructables.com/community/Your-Instr...

https://www.instructables.com/community/Cant-Publi...

https://www.instructables.com/community/Clicking-t...

DIYWEAPONS (author) 6 months ago

Right, so it ended up working out after a day, not sure what happened, thanks for all your replies, i would have written this sooner but since the major changes done to the website, i had a nightmare even finding this question again.. thanks guys for the help anyway

Kiteman6 months ago

See the other comments, and also make sure you have keywords separated, by, commas, like, this.

How many key words did you add and what channel did you pick.