loading
4Instructables25,653Views13Comments

Tell us about yourself!

Complete Your Profile

Achievements

10K+ Views Earned a bronze medal
Show 0 More »
  • Raspberry Pi 2 Homekit - from zero to Hey, Siri (Updated)

    Hello,Can someone please explain how to fix this issue?root@raspberrypi:/home/pi/HAP-NodeJS# npm install -g node-gypnpmWARNdeprecated minimatch@1.0.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issuenpmWARNdeprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issuenpmWARNengine hawk@3.1.3: wanted: {"node":">=0.10.32"} (current: {"node":"0.10.29","npm":"1.4.21"})npmWARNengine cryptiles@2.0.5: wanted: {"node":">=0.10.40"} (current: {"node":"0.10.29","npm":"1.4.21"})npmWARNengine boom@2.10.1: wanted: {"node":">=0.10.40"} (current: {"node":"0.10.29","npm"...see more »Hello,Can someone please explain how to fix this issue?root@raspberrypi:/home/pi/HAP-NodeJS# npm install -g node-gypnpmWARNdeprecated minimatch@1.0.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issuenpmWARNdeprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issuenpmWARNengine hawk@3.1.3: wanted: {"node":">=0.10.32"} (current: {"node":"0.10.29","npm":"1.4.21"})npmWARNengine cryptiles@2.0.5: wanted: {"node":">=0.10.40"} (current: {"node":"0.10.29","npm":"1.4.21"})npmWARNengine boom@2.10.1: wanted: {"node":">=0.10.40"} (current: {"node":"0.10.29","npm":"1.4.21"})npmWARNengine hoek@2.16.3: wanted: {"node":">=0.10.40"} (current: {"node":"0.10.29","npm":"1.4.21"})/usr/local/bin/node-gyp -> /usr/local/lib/node_modules/node-gyp/bin/node-gyp.jsnode-gyp@3.3.1 /usr/local/lib/node_modules/node-gyp├── graceful-fs@4.1.4├── osenv@0.1.3 (os-homedir@1.0.1, os-tmpdir@1.0.1)├── semver@5.1.0├── which@1.2.10 (isexe@1.1.2)├── nopt@3.0.6 (abbrev@1.0.9)├── fstream@1.0.10 (inherits@2.0.1)├── minimatch@1.0.0 (sigmund@1.0.1, lru-cache@2.7.3)├── mkdirp@0.5.1 (minimist@0.0.8)├── tar@2.2.1 (inherits@2.0.1, block-stream@0.0.9)├── glob@4.5.3 (inherits@2.0.1, once@1.3.3, inflight@1.0.5, minimatch@2.0.10)├── rimraf@2.5.2 (glob@7.0.4)├── npmlog@2.0.4 (ansi@0.3.1, gauge@1.2.7, are-we-there-yet@1.1.2)├── request@2.72.0 (is-typedarray@1.0.0, aws-sign2@0.6.0, oauth-sign@0.8.2, forever-agent@0.6.1, tunnel-agent@0.4.3, caseless@0.11.0, stringstream@0.0.5, isstream@0.1.2, json-stringify-safe@5.0.1, extend@3.0.0, aws4@1.4.1, node-uuid@1.4.7, combined-stream@1.0.5, qs@6.1.0, tough-cookie@2.2.2, mime-types@2.1.11, form-data@1.0.0-rc4, bl@1.1.2, http-signature@1.1.1, hawk@3.1.3, har-validator@2.0.6)└── path-array@1.0.1 (array-index@1.0.0)root@raspberrypi:/home/pi/HAP-NodeJS#

    View Instructable »