loading

When I apply a load to my voltage regulator, the output voltage drops. Why?

I'm trying to make a solar powered cell phone charger. I'm using a 5v 1A voltage regulator. When I have a dc input that is batteries, the voltage across the open output in 5.01v, as it should be. When I hook up a load, my phone, it stays at 5.01v. Now, when I hook up three solar panels rated at 3.5v 75mA a piece in series into the input, the output without a load is 5.01v. Then, when I ass my load, the voltage across the output drops to 4.7 something. What could cause this to happen? here's a picture on the two scenarios.

Picture of When I apply a load to my voltage regulator, the output voltage drops. Why?
circuit2.jpg
The regulator needs some breathing room. That is, voltage to regulate. At least a few volts more at the input will keep a comfortable 5v. Plus, the cell phone probably has some resistance in it.
Maybe a 10uF capacitor in parallel with your load will help.
AndyGadget8 years ago
2 problems :- 1) If the mobile phone requires more than 75mA to charge, the output will drop as the solar cells cannot supply the current - They will be 75mA only in very bright sunlight, and even then will drop when you apply a load, which brings me on to . .. 2) If you're using a standard 5V regulator (e.g. 7805) they require at least 3 volts more at the input than the output regulated voltage, so as soon as the solar cell voltage drops, the regulator will stop doing its job. What you need is a 6v rechargeable battery in parallel with the solar cells, and use a low dropout 5v regulator (e.g. LP2954) to the phone. This is only rated at 250mA, but will be enough for phone charging. The battery will charge up from the solar cells when it's bright and be ready for when you need to charge the phone.