loading

Here share my latest project, a router with acrylic shell and some leds.

This router has the below functions:

  • Let you know how many devices had connected to your router
  • Show you the real-time net speed by different color of the leds

If you like this router, please follow the below steps.

Cheers.

And thanks @Fiernocht and the other guys provide the ideas to protect your router, really useful

  1. password protect it
  2. set it to the highest encryption your devices can handle ie WPA2 and AES encryption.
  3. Ban any unauthroized MAC addresses on connection
  4. and final, Hide your SSID, by default it broadcasts to everyone

We made a new version of Router at 17 June, click to view ReRouter - Make an Extensible IoT Router

Step 1: What Do We Need

Step 2: The Drawing and Laser Cutting

I did some work on structures just as the picture shows. It’s made up of 3mm matte black acrylic board. My friend Xu from seeed help me cutting the board. I guess you don’t have a laser cutting at home, but still you can download the file and find some local hacker spaces to cut it. If there's no hacker space nearby, you can try the Laser Cutting Service supply by Seeed.

You can download my drawing shown as below by click here.

laser cutting

Now, you’ll need one piece of matte black acrylic (3mm 40cm*60cm), and cut the acrylic according by the drawing that you have already downloaded.

Step 3: Modules Connect

Prepare the cutting acrylic sheet and the circuit modules as the picture shows here.

The hardware connection and case assembly are quite simple.

Firstly lets fix the Arduino Breakout for LinkIt Smart 7688 Duo board to the acrylic board with screws and nuts. The Grove Led Strip is connected to the D6 port on the breakout board.

Then, insert LinkIt Smart 7688 Duo board to the Arduino Breakout board, finish the assembly of the router box as instructed in the following pictures.

Step 4: Set Up MT7688

Now, we should do some software work, if this is your first time to use MT7688, please put hand on http://www.seeedstudio.com/wiki/LinkIt_Smart_7688_Duo to get started.

If you are quite familiar with LinkItSmart 7688 already, please go to the MT7688 terminal by SSH or Serial.

  • Modify the configure file to change MT7688 Duo into router mode.
vi /etc/config/network
config interface 'lan'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '192.168.100.1'
config interface 'wan'
option ifname 'eth0'
option proto 'dhcp'

  • Enable yunbridge
> uci set yunbridge.config.disabled='0'<br>
> uci commit
  • set startup script
> chmod +x script/netDetermineBox
> cp script/netDetermineBox /etc/init.d/
> /etc/init.d/netDetermineBox enable
> /etc/init.d/netDetermineBox start &
> reboot

Step 5: Using Arduino IDE to Upload Arduino Sketch

  • Download demo code at https://github.com/Lee-Kevin/MT7688_Demo/tree/mas...
  • Click “Download zip” button on right side of webpage to download all codes.
  • Unzip the downloaded zip files to“C:\Users\Administrator\Documents\Arduino\” and remove “-master” in unzipped file name.
  • Launch Arduino IDE.
  • Click Sketch>Add file to add routerBox_Arduino.ino file from“C:\Users\Administrator\Documents\Arduino\MT7688_Demo\mt7688routerBox\
  • Press CTRL +U to upload codes to your board. Wait for a while until you see a prompt like following figure:

Now congratulations, you have just made an incredibly awesome DIY network router for yourself.

Step 6: ​The Result

Now,Power up the router, and access it to the network. Let your device connect to the “LinkIt_Smart _7688_xxxxxx”, and you’ll find the Green LED is light up

<p>&quot;...it turns out that someone is sneakily using it without my permission&quot;.</p><p>Forget making this thing. Learn to protect your router. </p><p>Also if I want to know how many devices are connected to the router I'd just use the free FING app on my cell phone. </p>
<p>You should use the newest WPA2 security protocol, hide your SSID and turn on MAC address filtering. In this case nobody can steal your wifi without your permission.</p>
<p>Hiding your SSID is a very stupid thing to do. Not only does it not really hide it as it gets broadcasted more frequently in the background, it makes it harder for everyone else to know what channel your router is on. The end result, you get others using the same channel as you are, slowing down your connection.</p>
Lol..Really? My wireless router selects the channel with the least activity.
Can they steal your Wi-Fi with your permission?
<p>mac address spoofers</p>
<p>you are joking right? wpa2 yes, but hiding your SSID is useless since you can use a certain tool in kali to reveal it, the mac filtering is useless as well since you acn spoof mac address</p>
<p>Hiding your SSID only hides it from yourself. Anyone who is trying to crack your wifi password sees the SSID and your Mac address in plain site.</p>
<p>and i just log into the administrative panel on my router and look in the &quot;connected devices&quot; tab. :P</p>
how can I make to make it a wireless router extender?
<p>Thank you for your post. I'm not a super hacker so I found it very interesting.</p><p>I'm looking for a router feature that is either DIY or even preferably, already a commercial solution. I need my router to trigger an external event based upon a specific MAC address connecting to it. I have different family members in the home and would like to be able to trigger home automation events when a particular MAC address connects, and disconnects. My current NETGEAR router gives me the ability to use my PC or smartphone to see who is connected, but I need this to be done automatically by perhaps sending the information over the ethernet to an arduino or other. Any feedback from you or others in the community would be greatly appreciated. If you suggest I post elsewhere for better exposure please advise as well. Thank you again!</p>
<p>I like the finished look of your project and am always envious of the Instructables community and their skills. In 1972 I made a couch out of 2x4s using just a saw and drill in an empty room. No table saw. No nothing. It looked like it but the bench thing worked for a while...</p><p>Acknowledging this is a 'fun' project and that i have embarked on many myself, there may be many here that are unaware of Ethernet and hubs. 20 years ago I set up local Ethernet networks that someone 50 feet outside the building could not get into nor anyone on the otherside of the planet using the Internet.</p><p>The convenience of the smart phone and tablet sacrifice security using WiFi and Cellular even if you have your own private server as one former Secretary of State did. She just didn't realize that email goes out in unencrypted text.</p><p>You can secure your fixed desktops and servers using Ethernet and cheap hubs and get safer and faster networking.</p><p>And if you use a Hub, as of 10+ years ago, each channel runs at full speed rather than dividing up the bandwidth.</p><p>I think Apple's latest WiFi routers as well as other companies broadcast on something like a fixed focus narrow beam rather than in a spherical pattern. This provides a bit more security.</p><p>One cool thing would be if someone could create an encryption system where each device would send a key with its request and the other would use the key to encrypt the message. Thus the key would be a random key and only good for that message and reply.</p>
<p>maybe a public/private rsa encryption for the password where the client encrypts the actual password using the broadcasted public key and the router decrypts with the private key.</p>
<p>maybe a public/private rsa encryption for the password where the client encrypts the actual password using the broadcasted public key and the router decrypts with the private key.</p>
<p>sounds like the old token ring network idea, A bit of re-working and you might be on to something.</p>
<p>cool, but changing the password and maybe have MAC fitering seems like a more secure option. Nevertheless I like it for its sheer coolness factor</p>
<p>don't forget about MAC address spoofing</p>
<p>don't forget about MAC address spoofing</p>
im not talking about password, since its a most secure thing you can do to secure your router. As i said before MAC filtering and hiding your ssid is useless... there is people who will only target those people who hide their SSID and set their channel -1.
<p>but I am talking about password</p>
<p>no, you talked about a password and maybe mac filtering.</p>
<p>yes indeed. How is that a problem or illegal. I dont get it. Anyway, enough time wasted on it</p>
<p>and hide your SSID so most script kiddies wont even know you exist.</p>
<p>well i believe that since windows 7 hidden ssid' s are indicated as 'other networks' which ofcourse will attract curiosity </p>
<p>Oh, the script kiddies will know you are there. Hiding your SSID does nothing really except make it hard for others to know what channels are in use.</p>
<p>mac filtering is useless...</p>
<p>not entirely. it will keep out the average Joe, just as hiding the ssid does. Safest is still a good password</p>
<p>I like the idea, but if &quot;someone is sneakily using it without my permission&quot;, then why not change the password? Or am I missing something?</p>
Password cracking software can get easy passwords within days if not hours or minutes.
<p>If you're not using complicated random passwords 20 characters or more then yes these programs will. The longer the password, the longer it takes these programs to get the password. 20 characters or more for a complicated random password takes these programs years, if not a century to get the password. Sure typing in such passwords are a pain, however you can copy and paste the password in.</p>
<p>Absolutely bang on, correct answer. Passwords are only as good as the length and character set used to create them. That's why we say to use mixed case alphanumerics and special characters. I use a SHA 256 hash generator, and the output of hashing a short, complex character set keyword becomes my wifi passphrase. Good luck doing a dictionary attack on a 64 character passphrase...won't find it in any wordlist that you can download :-)</p>
<p>what about hash collisions and wps password attacks... i hope your router has wps turned off :P. also aircrack and other software can capture a hash from your auth with your router and (given enough time) can find a collision for or the original password which will work on your router (though i doubt that any of your neighbors would go through all that trouble).</p>
<p>No if your hide your SSID. air-dump cannot get SSID that is not broadcast. </p>
<p>This is simply not true. The RF (radio frequency) signal is being broadcasted out in all direction whether you have SSID broadcasting enabled or not. So any wannabe badguy can search for RF signals and see your network regardless. And if you think airodump can't find SSID's, you are either just guessing, or you don't understand how to use airodump, becuse it can, I know I use the software all the time (I'm a security consultant).</p>
<p>correct...air-dump can't, but aireplay-ng can trigger a deauth and force a broadcast/reconnect..and air-dump can display/capture it.</p>
<p>No if your hide your SSID. air-dump cannot get SSID that is not broadcast. </p>
<p>As long as nothing is connected to the router, then your router will remain invisible to intruders. However, as soon as you connect something to the router, the SSID then becomes visible as it has to be broadcasted to the client in order to connect. Also as long as that client remains connected, the SSID will continue to be broadcasted to the client. While normal people won't be able to see the hidden SSID, intruders certainly will as they are monitoring the broadcasts.</p>
<p>Actual Reality: Even if the owner set the SSID as &quot;hidden&quot;, the SSID can still be read from probe and probe response packets monitored when another user connects. The BSSID can be used to filter for the probe packets and the BSSID can be had from the beacon frames that all APs send out, even if the SSID field in the beacon frame is &quot;hidden&quot;. Security always comes through encryption, never through obscurity.</p>
<p>No if your hide your SSID. air-dump cannot get SSID that is not broadcast. </p>
<p>False</p>
<p>I was thinking that if the router compatible, DD-WRT with a hardened password.</p><p>OTOH, if &quot;router&quot; is an integrated gateway, might explain it.</p>
<p>Hmm.. With 2 children in the house, 6 LED indication isn't enough.</p><p>Currently WiFi connected, I have... 1x Xbox One, 1x xbox360, 2xPS4 and a Wii.</p><p>3x laptops, 1x surface pro, 3x mobiles,2x ipads, 1x galaxy tab, 2x TV, 1x skyTV, 1x Rpi-3, 1x Wink, and a Tesla on the drive!</p><p>Perhaps replace the LEDs with a 16x2 LCD ?</p><p>Not to mention the 1Gb Ethernet connected devices (QNAP,3x servers, 2x PCs, etc).</p>
<p>6 LEDs are enough to tell you how many devices are connected in binary =]</p>
<p>Well, Maybe you're a nerd. The software of the router is open source, you can add LED indication by yourself.</p>
I think you've got my number :), I'm a Technical Designer for an ISP with nearly 30 year in the industry (10 of those as a C &amp; 4GL programmer), and I probably would, but I use a Juniper Firewall and Cisco AP at home, so don't really need to.<br>However, I do like this Instructable, I just thought I'd comment and give you some other ideas. I'll look forward to the Rpi3 post, and maybe you've inspired me to actually write an instructable too.
<p>BTW, I will write an instructable about Rpi-3, please keep an eye on instructables.com</p>
<p>Do you have a dimensioned drawing?</p>
<p>Hi, you can down load the file and get the dimensioned drawing, <a href="https://github.com/Lee-Kevin/13.DIYaRouter/tree/master/Drawing">https://github.com/Lee-Kevin/13.DIYaRouter/tree/ma...</a></p>
<p>how could you add extra Ethernet ports</p>
<p>Second this! I would love to hear more regarding additional ethernet ports.</p>

About This Instructable

121,478views

867favorites

License:

Bio: Howdy, we are application engineers in Seeedstudio. Sharing projects with maker community is awesome. Hope you like it XD
More by Seeed Studio:DIY a Gesture Keyboard That Can Control the Media Player Laser Cutting A Cool Science Fiction Gauntlet Make a Music Controlled Christmas Light With Arduino 
Add instructable to: