Tell us about yourself!

Complete Your Profile
  • Using Scanner in Canon MP-198 Without Ink or Cartridge

    Tried this with a Canon MP460, but didn't work.However, I did try the following:Hold Cancel Hold Power.Release Cancel.Press Cancel twice. (jam led toggles on and off)Release power.This gets to a state where the LCD shows 'Canon' in just plain text - not graphics. It feeds paper part way in. LCD then shows IDLE.But there is no USB activity and you cannot see the scanner.Pressing Cancel makes the jam and power leds alternate! But there doesn't seem to be a way to get the scanner to go. I tried various buttons, but none do anything except power and cancel.If you repeat again but press Cancel 4 times instead of twice, you get a language menu.After setting that, you get a message that just says "set the ink cartridge"If you then try scanning from PC, the screen shows scanning in p...

    see more »

    Tried this with a Canon MP460, but didn't work.However, I did try the following:Hold Cancel Hold Power.Release Cancel.Press Cancel twice. (jam led toggles on and off)Release power.This gets to a state where the LCD shows 'Canon' in just plain text - not graphics. It feeds paper part way in. LCD then shows IDLE.But there is no USB activity and you cannot see the scanner.Pressing Cancel makes the jam and power leds alternate! But there doesn't seem to be a way to get the scanner to go. I tried various buttons, but none do anything except power and cancel.If you repeat again but press Cancel 4 times instead of twice, you get a language menu.After setting that, you get a message that just says "set the ink cartridge"If you then try scanning from PC, the screen shows scanning in progress! Unfortunately it still doesn't scan.... Shame as I really thought I had cracked it!Oddly, the printer is now crashed and has to be powered off at the mains to recover....

    View Instructable »
  • rmarkham1 commented on SörenS7's instructable 3 Axis CNC Milling Machine1 year ago
    3 Axis CNC Milling Machine

    Thanks for getting back to me!Is there a complete Bill of Materials showing costs?I assumed that the parts from Germany would be a lot more expensive!One more question, how did you assemble the bed? I see you used separate ali profiles. Do they lock together or are there cross members underneath? I would imagine that there is a possibility of flex and vibration or resonance along the bed.Cheers!Richard.

    View Instructable »
  • rmarkham1 commented on SörenS7's instructable 3 Axis CNC Milling Machine1 year ago
    3 Axis CNC Milling Machine

    Great build! Would you share any drawings?Would round supported rails work OK?There are kits of rails, ballscrews and bearings on ebay, 3 axis for £210 from China. Not sure of the quality, but might make a cheaper build?

    View Instructable »
  • rmarkham1 commented on diy_bloke's instructable Arduino Controlled Light Dimmer1 year ago
    Arduino Controlled Light Dimmer

    Hi diy_bloke, couple of questions, if you have a moment. For a high current load, say 10kw, other than conductor size and triac rating and heatsink, is there anything else to consider with the high current? Is the zero crossing detector susceptible to noise spikes on the mains? I could easily to reject false triggers in software if it proved to be a problem.This is my final year project, please send all information to me immediately. (Ha ha! Not really, but I love those comments!) Thanks for your time!

    Hello again!For a heater load, where flicker is not a problem, do you think just switching the load completely off and on to regulate it, rather than chopping the cycles would be better or not? I would want to reduce stress on the element and also make sure there was no buzzing from it.

    Yes, my thoughts exactly!Thanks again!

    View Instructable »
  • rmarkham1 commented on diy_bloke's instructable Arduino Controlled Light Dimmer1 year ago
    Arduino Controlled Light Dimmer

    Great Instructable!

    Great posting and your patience with all the questions is amazing! Some of them are classics! It must be a full time job keeping up.I've learned a lot from your instructable, not having used a Triac before. Thanks for posting and taking the time to explain it in detail.

    View Instructable »
  • rmarkham1 commented on karawin's instructable Wifi Webradio with ESP8266 and VS10531 year ago
    Wifi Webradio with ESP8266 and VS1053

    One more question!ESP8266 is not connecting to my hub. It did connect once, but now it's always in AP mode. In boot up messages it says to "check your static ip"Any clue here:=> extraram state: 0 0xff ÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿdata : 0x3ffe8000 ~ 0x3ffe88d4, len: 2260rodata: 0x3ffe88e0 ~ 0x3ffeac8c, len: 9132bss : 0x3ffeac90 ~ 0x3fff1ad0, len: 28224heap : 0x3fff1ad0 ~ 0x40000000, len: 58672Heap size: 30888t0 task: 3fff8908t1 task: 3fff8aa0t4 task: 3fff8ff8t3 task: 3fff9618t2 task: 3fffa368mode : sta(5c:cf:7f:04:e9:78)add if0UART READY TO READAP1: BTHub5-NFGF, AP2: Station Ip: 0.0.0.0Trying BTHub5-NFGF, I: 0 status: 1SCI_Mode (0x4800) = 0x4802SCI_Status (0x48) = 0x4CVS Version (VS1053 is 4) = 4SCI_Cloc...

    see more »

    One more question!ESP8266 is not connecting to my hub. It did connect once, but now it's always in AP mode. In boot up messages it says to "check your static ip"Any clue here:=> extraram state: 0 0xff ÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿdata : 0x3ffe8000 ~ 0x3ffe88d4, len: 2260rodata: 0x3ffe88e0 ~ 0x3ffeac8c, len: 9132bss : 0x3ffeac90 ~ 0x3fff1ad0, len: 28224heap : 0x3fff1ad0 ~ 0x40000000, len: 58672Heap size: 30888t0 task: 3fff8908t1 task: 3fff8aa0t4 task: 3fff8ff8t3 task: 3fff9618t2 task: 3fffa368mode : sta(5c:cf:7f:04:e9:78)add if0UART READY TO READAP1: BTHub5-NFGF, AP2: Station Ip: 0.0.0.0Trying BTHub5-NFGF, I: 0 status: 1SCI_Mode (0x4800) = 0x4802SCI_Status (0x48) = 0x4CVS Version (VS1053 is 4) = 4SCI_ClockF = 0xB800I2S Speed: 0plugin size 18ce 2 c67plugin start: 7 1 8050 6scandonestate: 0 -> 2 (b0)Trying BTHub5-NFGF, I: 1 status: 1state: 2 -> 3 (0)state: 3 -> 5 (10)add 0aid 4pm open phy_2,type:2 0 0cntconnected with BTHub5-NFGF, channel 10check your static ip!Trying BTHub5-NFGF, I: 2 status: 1Trying BTHub5-NFGF, I: 3 status: 1Trying BTHub5-NFGF, I: 4 status: 1Trying BTHub5-NFGF, I: 5 status: 1state: 5 -> 0 (0)rm 0pm close 7 0 0/20001334Config not foundThe default AP is WifiWebRadio. Connect your wifi to it.Then connect a webbrowser to 192.168.4.1 and go to SettingErase the database and set ssid, password and ip's fielddel if0uslmode : softAP(5e:cf:7f:04:e9:78)dhcp server start:(ip:192.168.4.1,mask:255.255.255.0,gw:192.168.4.1)add if1bcn 100autostart: playing:1, currentstation:0I2S Speed: 0##CLI.STOPPED# from playStationInt##CLI.NAMESET#: 0##CLI.URLSET#:##CLI.PATHSET#:##CLI.PORTSET#: 0##CLI.OVOLSET#: 0##CLI.STOPPED# from clientConnect##CLI.VOL#: 120##CLI.STOPPED# from Adc Stop##CLI.VOL#: 130##CLI.VOL#: 140

    Ha! Thanks very much! It changed since my first build!

    I've just built another karadio using an ESP12 module.I cannot set the uart to 28800 though.It's running v1.1.5.terminal connected just responds with#INFO:"cli.uart("28800")"#cli.vol("123") works ok.Help!

    Is there any special format required for the radio stations list file?

    View Instructable »
  • rmarkham1 commented on karawin's instructable Wifi Webradio with ESP8266 and VS10531 year ago
    Wifi Webradio with ESP8266 and VS1053

    All good! It works great. Many thanks!Is there a list of commands via the com port?Just about to add an Arduino and screen now.Where should I donate?

    OK, working now. Seems it need a power reset after flashing. LED is flashing now and webpage loads correct!

    Pasted image didn't show. here are the settings I used...

    Hi, I am having a problem getting initial wifi connection to EPS8266.I have flashed the device.PTTY connect to is shows:=> extraram state: 0 0xff ÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿdata : 0x3ffe8000 ~ 0x3ffe88d4, len: 2260rodata: 0x3ffe88e0 ~ 0x3ffeab58, len: 8824bss : 0x3ffeab58 ~ 0x3fff19a0, len: 28232heap : 0x3fff19a0 ~ 0x40000000, len: 58976Heap size: 31192t0 task: 3fff87d8t1 task: 3fff8970t4 task: 3fff8e60t3 task: 3fff9480t2 task: 3fffa1d0mode : sta(a0:20:a6:12:2f:25)add if0UART READY TO READAP1: , AP2:first use Station Ip: 192.168.1.254Trying , I: 0 status: 0Config not foundThe default AP is WifiWebRadio. Connect your wifi to it.Then connect a webbrowser to 192.168.4.1 and go to SettingErase the database and set ...

    see more »

    Hi, I am having a problem getting initial wifi connection to EPS8266.I have flashed the device.PTTY connect to is shows:=> extraram state: 0 0xff ÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿdata : 0x3ffe8000 ~ 0x3ffe88d4, len: 2260rodata: 0x3ffe88e0 ~ 0x3ffeab58, len: 8824bss : 0x3ffeab58 ~ 0x3fff19a0, len: 28232heap : 0x3fff19a0 ~ 0x40000000, len: 58976Heap size: 31192t0 task: 3fff87d8t1 task: 3fff8970t4 task: 3fff8e60t3 task: 3fff9480t2 task: 3fffa1d0mode : sta(a0:20:a6:12:2f:25)add if0UART READY TO READAP1: , AP2:first use Station Ip: 192.168.1.254Trying , I: 0 status: 0Config not foundThe default AP is WifiWebRadio. Connect your wifi to it.Then connect a webbrowser to 192.168.4.1 and go to SettingErase the database and set ssid, password and ip's fielddel if0uslmode : softAP(a2:20:a6:12:2f:25)dhcp server start:(ip:192.168.4.1,mask:255.255.255.0,gw:192.168.4.1)add if1bcn 100autostart: playing:0, currentstation:0add 1aid 1station: 00:1e:4c:7d:3b:b4 join, AID = 1I connect my laptop to WiFiWebRadio SSID and it connects.Try browsing 192.168.4.1 and I get "Unable to Connect"This is the flash settings I used which is slightly different as there is newer version of the flash tool:Any ideas?Thanks!

    View Instructable »