author

robboz4

4
Inbox View Profile
5Instructables5,308Views15Comments

Tell us about yourself!

Achievements

  • How to Make Chinese Egg Tarts

    Thanks for this great recipe! I've lost count of how many I've made. This is the latest batch!

    View Instructable »
  • robboz4 commented on a-RN-au-D's instructable OPEN LASER BLASTER
    OPEN LASER BLASTER

    Great Project!In the process of building it now!

    View Instructable »
  • robboz4's instructable PiGMI's weekly stats:
    • PiGMI
      141 views
      0 favorites
      0 comments
  • robboz4 entered PiGMI in the Raspberry Pi Contest 2020 contest
  • robboz4 commented on robboz4's instructable Automated Singing Pumpkins

    Thanks for the fix, but no idea why that fixes it as a few lines further up there is a an "if.." statement without the "()". Anyway I have uploaded a new version that actually passed Mu, and has been running on my Zero for several hours. There is also a "-r" option now that will make the relays work the normal way. Please download the latest and this time you should be good to go.

    View Instructable »
  • robboz4 commented on robboz4's instructable Automated Singing Pumpkins

    Totally weird as the code I was running I just uploaded to gitlab. I’ll look a the Mu editor issue as it might be I have to remove all space and put in tabs. The error could be a few lines up or an invisible character (newline or something) has got in the code and the editor is trying to parse it. Try downloading the code again, but do not open it in an editor. Just try running it on the Pi from command line. I can see I will have to invest in Pi 4 or you will have buy Pi Zero :-)

    Totally weird as the code I was running I just uploaded to gitlab. I’ll look a the Mu editor issue as it might be I have to remove all space and put in tabs. The error could be a few lines up or an invisible character (newline or something) has got in the code and the editor is trying to parse it. Try downloading the code again, but do not open it in an editor. Just try running it on the Pi from command line. I can see I will have to invest in Pi 4 or you will have buy Pi Zero😁

    Totally weird as the code I was running I just uploaded to gitlab. I’ll look a the Mu editor issue as it might be I have to remove all space and put in tabs. The error could be a few lines up or an invisible character (newline or something) has got in the code and the editor is trying to parse it. Try downloading the code again, but do not open it in an editor. Just try running it on the Pi from command line. I can see I will have to invest in Pi 4 or you will have buy Pi Zero😁

    Totally weird as the code I was running I just uploaded to gitlab. I’ll look a the Mu editor issue as it might be I have to remove all space and put in tabs. The error could be a few lines up or an invisible character (newline or something) has got in the code and the editor is trying to parse it. Try downloading the code again, but do not open it in an editor. Just try running it on the Pi from command line. I can see I will have to invest in Pi 4 or you will have buy Pi Zero😁

    View Instructable »
  • robboz4 commented on robboz4's instructable Automated Singing Pumpkins

    Ok you should be good to go now. Worked out all the spaces/ tabs issues. There could still be a slight wrinkle on the relays though. If they all come on when the program starts, use the NC output pins on the relays. I’m working on a parameter to pass in if this happens. It seems some relays want a 0 to operate and others a 1! But the NC outputs should work... thanks for the patience and extra testing! Use the previous link for the code.

    View Instructable »
  • robboz4 commented on robboz4's instructable Automated Singing Pumpkins

    Weird! The code is running fine and all I did was upload it. But will check tomorrow. Hopefully I’ll have you up running before Halloween!

    View Instructable »
  • robboz4 commented on robboz4's instructable Automated Singing Pumpkins

    Ok all done and tested: https://gitlab.com/robboz4/instructable_code/tree/...I added the extra 2 relays in as well. Read the gitlab page and it should explain what I did and how it is wired up. Have fun!

    Ok all done and tested: https://gitlab.com/robboz4/instructable_code/tree/...I added the extra 2 relays in as well. Read the gitlab page and it should explain what I did and how it is wired up. Have fun!

    View Instructable »
  • robboz4 commented on robboz4's instructable Automated Singing Pumpkins

    Oh the joys of getting old! The code I posted didn't have the relay GPIO pins in! Argh!!! Let me go back to the code and get the relay added. I''ll add 4 relays for you and let you know the pins. Might take a couple of days. Stay tuned.

    View Instructable »
  • robboz4 commented on robboz4's instructable Automated Singing Pumpkins

    Yes it's probably an issue with Python and mixing tabs and spaces for indenting. Not sure how you feel about fixing code, but you could try looking at the code with a text editor to display hidden characters and fix it that way. But I'll have a look myself to see what I did. It is working fine on an old installed version, but I haven't updated the Pi OS or python for a while. I had this happen to me on another project switching from Python2 to Python3 so will go back and look. I'm building one for a friend right now so this will be a good time to fix it. Do you know what version of Python you have?If you want you can download this script I wrote to capture all the information:https://gitlab.com/robboz4/PiDiagthen send me the output.It might be a couple of days before I post a fix.Chee…

    see more »

    Yes it's probably an issue with Python and mixing tabs and spaces for indenting. Not sure how you feel about fixing code, but you could try looking at the code with a text editor to display hidden characters and fix it that way. But I'll have a look myself to see what I did. It is working fine on an old installed version, but I haven't updated the Pi OS or python for a while. I had this happen to me on another project switching from Python2 to Python3 so will go back and look. I'm building one for a friend right now so this will be a good time to fix it. Do you know what version of Python you have?If you want you can download this script I wrote to capture all the information:https://gitlab.com/robboz4/PiDiagthen send me the output.It might be a couple of days before I post a fix.Cheers

    Try this link:https://gitlab.com/robboz4/instructable_code/tree/...It turns out I had added support for an 8 Channel relay board and other functionsto my original project, but forgot to update the instructable. The above link is the basic code described in the article. There should be no ident errors anymore. Just make sure to get the PIR and relays on the correct GPIO pins.Have fun!

    View Instructable »
  • robboz4 commented on robboz4's instructable Automated Singing Pumpkins

    There is a link at the end of step3 “Halloween Control” or try this link.https://github.com/robboz4/Halloween-Control

    View Instructable »
  • robboz4's instructable Logo Lit by LED's weekly stats:
    • Logo Lit by LED
      41 views
      0 favorites
      0 comments
  • I have made these several times now and they have all turned out excellent. Thanks for sharing the recipe.

    View Instructable »
  • robboz4's instructable Automated Singing Pumpkins's weekly stats:
    • Automated Singing Pumpkins
      194 views
      6 favorites
      1 comments