Olympus OM10 Sticky Shutter Repair

Introduction: Olympus OM10 Sticky Shutter Repair

About: I love fixing things...

Olympus OM series are awesome, these are tiny cameras. They are versatile, come with a large and bright viewfinder, and OM lenses are very compact with awesome optical and build quality.

Olympus OM10 is one of the lower spec OM bodies, which can be obtained second hand fairly easily. A common failure is the sticky shutter situation, where the exposure time is significantly longer at first use after a long unused period. For instance, LED indicator shows 1/1000, but the first exposure is something like 1/30 or 1/15, pretty long. In most cases, the subsequent exposures are spot on.

The reason is that oil migrates onto the shutter magnets which causes them to stick open. This is fairly easy to fix, you just need to clean the shutter magnet assembly using 99% Isopropyl Alcohol.

For this instructable you just need:
- Flat tip screwdriver
- 99% Isopropyl Alcohol
- Cotton swabs
- Masking tape (or any other weak sticky tape)

Step 1: Tape the Mirror to the Top Position

I used a weak masking tape. This is to open work space and protect the fragile mirror surface. Things are much harder to deal with with the mirror down.

Step 2: Lift the Mirror Box Bottom Cover

Do this using a flat tip screw driver. Start from the left edge and it will lift easily. Take the plastic cover out.

Step 3: Locate the Electromagnet and Soak It With Pure Alcohol

Check out the photos below, there is a tiny electromagnet and several metal heads touching it. This is our problem area. Soak a cotton swab with pure alcohol (99% Isopropyl Alcohol) and spread it over the left edge of the electromagnet. Operate the camera several times and try again. This will help cleaning/draining the oil residue on the magnet surface.

Step 4: Put the Cover Back, You Are Done!

Put the cover back resting it on its right edge and lowering the left edge, as shown below. Your sticky shutter problem must have gone now. Fire the shutter several times. Rest the camera for a few hours, and try firing the shutter again. Most probably the problem have vanished. Otherwise, follow the previous steps again.

Happy snaps!..

K.

Be the First to Share

    Recommendations

    • Plywood Challenge

      Plywood Challenge
    • Plastic Contest

      Plastic Contest
    • Battery Powered Contest

      Battery Powered Contest

    11 Discussions

    0
    Daral3
    Daral3

    3 years ago

    Will give this a try on OM-PC body.

    0
    JessicaG6
    JessicaG6

    5 years ago on Introduction

    Totally blown away that this works! I just got an OM-10 at Goodwill. The the mirror was tripping avery time i used the film advance, and the trigger wasn't resetting. I used an eyedropper to get denatured alcohol into the correct area. I had no issues removing the bottom plate, but since I was assuming the camera was junk, I may have been aggressive than these other folks. The only hang up I had was two felt strips, which I just pushed back into place.

    0
    alex.forbath
    alex.forbath

    5 years ago

    I have the same problem as Jordan. Anyone know how to remove the bottom plate screw?

    0
    JordanR3
    JordanR3

    5 years ago on Introduction

    Can't lift out the plastic piece because there's a pin in the way, which is stopping it. Is there a setting that it's supposed to be on?

    0
    amontemurno
    amontemurno

    8 years ago on Introduction

    This did the trick! great instructions, now I can focus! on getting to know this old school, 35Mm camera and use for school!! thanks soooooo much!
    AMM

    0
    jimdigriz
    jimdigriz

    8 years ago on Step 4

    This worked a treat. Simple clear concise. Saved me throwing a perfectly usable camera away. Thanks!!!!

    0
    akaarina
    akaarina

    9 years ago on Step 4

    Well done! Nice job !!
    Me too I have an OM10. It's like new and everything go smooth.
    The only problem is that when i use B setting (bulb), the shutter will not close after i release the button and remains open.
    It will close only after I rewind again so loosing a pose.

    Do Y have any idea of what appens to my OM 10 ??

    Thank Y for the answer.

    0
    fotocianado
    fotocianado

    10 years ago on Step 4

     good stuff!!!!  found a "broken" OM10 in my local camera store's bargain bin for $5 and bingo this fixed it :)

    0
    enriquo91
    enriquo91

    11 years ago on Step 2

    Hey mate, Do you think this solution would work the om40? I've been looking for a solution forever!

    0
    rewilliams
    rewilliams

    11 years ago on Step 3

    Almost correct, but you would be better soaking in alcohol a small (strong) piece of paper cut 3mm high, putting it between the magnet faces. push the moving arm of the magnet together and then draw the paper out. This will clean both faces. Do it a couple of times clean paper each time. If the paper breaks its too thin.