Introduction: Swagway, Hover Board, IScooter Fix Uncontrollable Jitter SkyWalker

About: iOS Developer, Love to create and hack. Internet of things enthusiast. Cocoa Head, Tech geek, @StartUpGrindUtah #IoT #3Dprinting #runner

This is the second problem that commonly effects the Swagway / iScooter / Hover board / Chinese what ever. So you should check out the first intractable if you have not tried that solution yet. It is definitely the easiest fix if that is the problem

But if you get off your board and it shakes uncontrollably then this is probably the solution for you.

What will need for this fix:

Small Philips head screw driver that is the one with the +.

A pair of scissors.

Step 1: Remove the Screws From the Bottom of the Swagway.

Their are 10 screws for each side of the board. Some of the screws are different. The 4 closest to the center of the board and the outer most 4. They just screw into the other half of the bodies shell. They are shorter and pointy. You will need to remove all 20 screws. Once you have removed the screws the bottom portion of the board should come off. They will still be attached by some wires, on one side this is just for the LEDs. You can take your screw driver or a knife and pry at the Hot Glue off of the connectors or you can just leave them. On the other side you also have the power connectors for recharging the battery and the power button wires.

Step 2: Remove More Screws.

There are 6 screws that hold on the top half of the shell. They are pictured on where they are located 6 pretty obvious and then two right by the wheel. This will allow the top pieces to lift off. Be careful there is a wire that is attached also. This reveals the pressure plate witch is the source of the problem.

Step 3: The Root of the Problem.

So the reason for the jitter is the rubber pad that you step on. It is supposed to have a vent to let the trigger compress and decompress. There is a little shaft that slides down once you step on the board that blocks an optical sensor. If the foot pad cannot deflate the shaft stays blocking the sensor and essentially the board is still trying to balance itself but your not on it.

Picture 1 is the area that is supposed to fill with air so that the pad can lift up and the board can disengage.

Picture 2 Shows you where you need to make the cut. All your trying to do it increase its ability to compress and decompress so finding the middle of the foot pad. There is a groove that goes along the middle and lines up with that chamber. Fallow that to the edge and cut out a small section only needs to be like a centimeter in and 2 or 3 cm long. This way it wont be visible when we put it all together. This is featured in Picture 3.

Step 4: Reassemble the Beast.

Now for the hard part, putting it all back together. Take the rubber foot pad and place it back in the top portion of the shell. Place the plastic support on the board and place the top half of shell onto board. Screw back in the 8 screws that hold the top section on. Reconnect your LEDs and place the bottom sections on. I would only put in 3 or 4 screws and test to see that it works that way you don't have to take them all out if it does not. Then fallow up and finish putting the rest of the screws in. Remember that the shorter screws go on the center and out side edge.

There your problem should be solved. If you are getting the Red Ring of Death I would suggest recalibrating the board. Instructions on how to do that are found here.

If that does not solve your problem then you need to do the third fix which can be found here

Thanks for reading let me know if you found another problem or any of the steps were wrong.

Also if you want to know how to get google to mow your lawn check out

Step 5: