109Views15Replies

Author Options:

Unable to ask a question anonymously Answered

I am unable to post a question anonymously. It will allow me to fill out the form to do so, but when I hit "preview", I am sent to a login page. It will only allow me to continue if I enter my username and password. I followed the link from the home page, and I logged out to try this. OS - Vista Tested in the following browsers: FireFox v 3.0.5 Chromium v 2.0.159.0 (8613) Chrome v 1.0.154.43 Internet Explorer v 7.0.6001.18000 (bleh!)

Discussions

0
user
rachel

9 years ago

I believe this is fixed now. It was an intermittent issue involving the differences between the production environment and the development environments. Everyone, please post a comment here if you are still unable to ask an anonymous question (with details as in the original forum topic).

Try using a proxy?

Okay, I don't think this is actually a bug. You cannot create anonymous Forum topics (or I'bles) either.

If you access I'bles anonymously, and navigate to a Forum, you can click the [New Topic] button. It will bring up the regular login page, and after you've logged in it will redirect you back to the text entry form for creating a Forum topic.

The Ask a Question part of the new Answers is equivalent to creating a new topic, so I'm not surprised it behaves the same way.

Well, I thought it was a bug because Ewilhelm specifically said "you don't even need to create an account or log in". But I could be wrong.

Ah! Then its a missing feature :-) It's pretty clear that they implemented Questions by reusing all of the very nice topic-creation code, just defining a new "type" value (that's the "/tag/type:question/" part of the URL for the Answers list).

If Eric (as you say) wants anonymous Questions, then the Dev team has some work to do :-)

I spy with my little eye...something ungrammatical... :D
Rachel! Get back to work! >Cracks whip<

Pah! I spit on your whip! Actually if you really want to ask a question anonymously, you have to log out to do so, and simply use a different email address to get your answer notifications.

:D I tried that...no joy. Do ya'll not like tempinbox.com or something?

Can you be more specific about the joylessness? PM me if you want, but in order to track this down I'll need to know details like exactly what you entered, on what page, your login status at the time, the error message (if any) that you got, or just What Happened Next (see Writing a useful bug report for extra detail). Thanks!

Oh, sorry. Sure, in fact I can go into painful detail. :D I've tried this many times. The most recent time, I logged out and deleted alll my cookies just to be sure. Then I asked "How much does Rachel rock?" (Yes really. Yes, I wanted to frame you. :D) by entering it into the box on the front page. Then it went to the page to enter more information. In the body I put "What do you think?". Around this time I started longing for oreos, but I held my ground and continued to input data. I used the email adrianmonk95ATyahooDOTcom (junk email). I entered it in category Life and entered "life" as the only keyword. I entered the capcha. Then I hit preview and it redirected me back to the login: page.

OK I can reproduce this. Must have added that one last night when fixing a couple other bugs, because it Used To Work (tm)! I should have a fix up soon. Thanks for reporting it!

Oh, forgot to say, no error messages unless you count the "login:".

0
user
noahw

9 years ago

This is not a bug. We've begun recognizing email addresses that are associated with user accounts and prompting those already linked to an Instructables account to log in before asking their question. If you'd like to post an completely anonymous question you'll have to get a new email address, that's not already linked to your user name and submit your question as a guest. For new email addresses, the guest feature is working fine.

It may just be a problem on my end then, but I can't get it to work with a new email address. Not that I'm hot to post anonymous questions, but hopefully it's not happening to lots of other people.

Hi, Adrian. The redirection to the login page must be a bug. However, the requirement to be logged in seems to be generic. I just tried looking at this bug report anonymously. When I hit "Add Comment" it gave me the green popup asking for my username/password. Now it has my "You" tabs up in the masthead, and "preview" seems to work fine. My next test is going to see if creating a Forum Topic (which is really what "ask a question" does) has the same behaviour, or if it shows the same bug you're reporting...