New Site Search Doesn't Work on Chrome on Mac Answered


Author Options:

I'm running Chrome 27.0.1453.47 beta on a MacBook Pro running OS 10.8.3 and I can type in the new search box on the main homepage but it doesn't search when I hit return or when I click on the magnifying glass. It worked in Firefox though.  I've disabled adblock to see if that was the cause of the issue and that didn't help either.  Anyone else have this issue?  I've had a lot of issues with Chrome on the Mac with this site, including when editing instructables.  I couldn't even submit this bug report on Chrome because the "Preview Topic" button would not do anything when clicked.


Any script blocking add on (like AdBlock) will stop the site from loading correctly/displaying information. That said, even without AdBlock the site is acting weird on Chrome since the latest release. We're working on buttoning that up, in teh meantime the site is very stable on Firefox.

I've also experienced this on the front page search in Chrome. I found disabling my password manager was effective. It's made me very curious as to the cause.

Nice to know you are working on the issues with Chrome. It seems there are many functionality buttons to submit items that do nothing. I've had issues in Safari as well. I recently won a prize where there is apparently supposed to be a field to select a t-shirt size or add further instructions (like a color request), but in no browser, including firefox do I get anything other than an address entry.

also, lot's of issues with trying to upload and attach images. I go through the whole process, but after upload...nothing. Later I see the images in my "pool" of images. I tried posting an image to my previous entry but had the same issue.

Ive had other sites that wont work properly with chrome, any site that use been built with apples Iweb seem to have issues also. If you like fast striped down browsers try seamonkey.